Author: imp
Date: Mon Feb 12 14:48:14 2018
New Revision: 329164
URL: https://svnweb.freebsd.org/changeset/base/329164

Log:
  We don't support gcc < 4.2.1, so varargs.h now is just #error
  always. Unifdef for versions prior to 4.2.1 and remove now-unused
  header files.
  
  Sponsored by: Netflix
  Differential Revision: https://reviews.freebsd.org/D14323

Deleted:
  head/sys/amd64/include/varargs.h
  head/sys/i386/include/varargs.h
  head/sys/mips/include/varargs.h
  head/sys/powerpc/include/varargs.h
  head/sys/sparc64/include/varargs.h
Modified:
  head/include/varargs.h

Modified: head/include/varargs.h
==============================================================================
--- head/include/varargs.h      Mon Feb 12 14:48:05 2018        (r329163)
+++ head/include/varargs.h      Mon Feb 12 14:48:14 2018        (r329164)
@@ -31,15 +31,7 @@
 #ifndef _VARARGS_H_
 #define        _VARARGS_H_
 
-#if defined(__GNUC__) && (__GNUC__ == 3 && __GNUC_MINOR__ > 2 || __GNUC__ >= 4)
-
-#error "<varargs.h> is obsolete with this version of GCC."
+#error "<varargs.h> is obsolete."
 #error "Change your code to use <stdarg.h> instead."
-
-#else  /* ! __GNUC__ post GCC 3.3 */
-
-#include <machine/varargs.h>
-
-#endif /* __GNUC__ post GCC 3.3 */
 
 #endif /* !_VARARGS_H_ */
_______________________________________________
svn-src-all@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-all
To unsubscribe, send any mail to "svn-src-all-unsubscr...@freebsd.org"

Reply via email to