Author: delphij
Date: Sat Apr  6 03:42:15 2019
New Revision: 345976
URL: https://svnweb.freebsd.org/changeset/base/345976

Log:
  Write string constant differently to improve readability.
  
  Reported by:  rgrimes
  Reviewed by:  rgrimes, emaste
  MFC after:    13 days
  Differential Revision:        https://reviews.freebsd.org/D19829

Modified:
  head/sbin/fsck_msdosfs/dir.c

Modified: head/sbin/fsck_msdosfs/dir.c
==============================================================================
--- head/sbin/fsck_msdosfs/dir.c        Sat Apr  6 02:39:56 2019        
(r345975)
+++ head/sbin/fsck_msdosfs/dir.c        Sat Apr  6 03:42:15 2019        
(r345976)
@@ -444,10 +444,8 @@ checksize(struct bootblock *boot, struct fatEntry *fat
        return FSOK;
 }
 
-static const u_char dot_name[] = {
-       '.', ' ',' ',' ',' ',' ',' ',' ',' ',' ',' ' };
-static const u_char dotdot_name[] = {
-       '.', '.',' ',' ',' ',' ',' ',' ',' ',' ',' ' };
+static const u_char dot_name[11]    = ".          ";
+static const u_char dotdot_name[11] = "..         ";
 
 /*
  * Basic sanity check if the subdirectory have good '.' and '..' entries,
_______________________________________________
svn-src-head@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/svn-src-head
To unsubscribe, send any mail to "svn-src-head-unsubscr...@freebsd.org"

Reply via email to