On 02/04/18 04:33, O. Hartmann wrote:
Am Mon, 29 Jan 2018 05:00:22 -0800
David Wolfskill <da...@catwhisker.org> schrieb:

On Mon, Jan 29, 2018 at 02:10:04AM -0800, Jason Harmening wrote:

This happens now if PORTS_MODULE=x11/nvidia-driver is defined in /etc/src.conf:

--- kernel-install ---
mkdir -p /boot/kernel
install -p -m 555 -o root -g wheel kernel /boot/kernel/
--- ports-install ---
Variable OBJTOP is recursive.

make[8]: stopped

David sent me logs of the failing case; thanks David!

Happy to help! :-)

The failure happens when buildkernel and installkernel are run
separately instead of all-up, e.g. 'make kernel'.  The installkernel
step is leaving MK_AUTO_OBJ=no in the env passed to the port build.  It
looks like at least one of the install stages of nvidia-driver needs to
generate temporary output, which leads to confusion when the port isn't
built as though it's an in-tree component.

Can you guys try out the attached patch?

I tried it both on my build machine (which does not use kernel modules
from ports, and thus did not exhibit the problem -- but I thought that
verifying that the patch did not break that case worth checking) and on
my laptop (which did exhibit the problem).

It worked in both cases with no issues for me.

Thanks! :-)


The problem still persists!

I'm on CURRENT, FreeBSD 12.0-CURRENT #32: Sun Feb  4 09:41:39 CET 2018 amd64, 
the source
tree is at revision 328839.

I use WITH_META_MODE=YES in /etc/src.conf. My /etc/make.conf consists of a 
statement which reels in /usr/local/etc/ports.conf in which I define everything 
the source tree for ports (in case of the nvidia driver, its DISTVERSION). This 
before and should work again. Today I checked out a completely fresh /usr/src 
and gleanced
the /usr/obj folder and rebuilt the system - and get the error again:

===> Ports module x11/nvidia-driver (install)
cd ${PORTSDIR:-/usr/ports}/x11/nvidia-driver; env  -u CC  -u CXX  -u CPP  -u 
Looks like you haven't applied the patch? MK_AUTO_OBJ being left set in MAKEFLAGS by installkernel was part of the problem.

That said, the fix I have up for review is slightly different:

TARGET=amd64 TARGET_ARCH=amd64"  SYSDIR=/usr/src/sys
SRC_BASE=/usr/src  OSVERSION=1200056  
make -B deinstall reinstall ===>  Deinstalling for nvidia-driver ===>   
nvidia-driver-387.34 Updating database digests format: . done Checking 
integrity... done
(0 conflicting) Deinstallation has been requested for the following 1 packages 
(of 0
packages in the universe):

Installed packages to be REMOVED:

Number of packages to be removed: 1

The operation will free 99 MiB.
[1/1] Deinstalling nvidia-driver-387.34...
[1/1] Deleting files for nvidia-driver-387.34: .......... done
===>  Staging for nvidia-driver-387.34
===>   nvidia-driver-387.34 depends on file: /usr/local/lib/libGL.so - found
===>   nvidia-driver-387.34 depends on file: 
/usr/local/libdata/pkgconfig/x11.pc - found
===>   nvidia-driver-387.34 depends on file: 
- found ===>   nvidia-driver-387.34 depends on file: 
- found ===>   Generating temporary packing list
===> src (install)
===> src/nvidia (install)
Variable OBJTOP is recursive.

make[8]: stopped
*** Error code 2


svn-src-head@freebsd.org mailing list
To unsubscribe, send any mail to "svn-src-head-unsubscr...@freebsd.org"

Reply via email to