> I can't find anything about Cocoa Delegate/Datasource protocol "Grand 
> Renaming" for Swift 3
> Is something planned about this ?
> 
> Because I find that actual names don't fit with Swift 3 API guidelines.
> 
> For instance : 
> 
> func numberOfSectionsInTableView(_ tableView: UITableView) -> Int
> func tableView(_ tableView: UITableView, numberOfRowsInSection section: Int) 
> -> Int
> func tableView(_ tableView: UITableView, cellForRowAtIndexPath indexPath: 
> NSIndexPath) -> UITableViewCell
> func tableView(_ tableView: UITableView, moveRowAtIndexPath sourceIndexPath: 
> NSIndexPath, toIndexPath destinationIndexPath: NSIndexPath)
> 
> func tableView(_ tableView: UITableView, heightForRowAtIndexPath indexPath: 
> NSIndexPath) -> CGFloat
> func tableView(_ tableView: UITableView, didSelectRowAtIndexPath indexPath: 
> NSIndexPath)
> ...
> 
> could be renamed to something like this : 
> 
> func numberOfSections(in tableView: UITableView) -> Int
> func numberOfRows(inSection section: Int, in tableView: UITableView) -> Int
> func cellForRow(at indexPath: NSIndexPath, in tableView: UITableView) -> 
> UITableViewCell
> func moveRow(at sourceIndexPath: NSIndexPath, to destinationIndexPath: 
> NSIndexPath, in tableView: UITableView)
> 
> func heightForRow(at indexPath: NSIndexPath, in tableView: UITableView) -> 
> CGFloat
> func didSelectRow(at indexPath: NSIndexPath, in tableView: UITableView)
> ...

Short version is, we couldn't find any obvious way to translate delegates, so 
we punted on it.

-- 
Brent Royal-Gordon
Architechies

_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution

Reply via email to