For what it's worth, you can drop the "get" part for read-only computed properties and write:
var session: AVCaptureSession { return layer.session } On Sat, Oct 7, 2017 at 7:07 AM James Valaitis via swift-evolution < swift-evolution@swift.org> wrote: > Is it widely agreed that it is necessary to require a return statement on > a one line property getter? > > var session: AVCaptureSession { get { return layer.session } } > > Or could we follow the convention for any other close and get rid of it? > For me it seems redundant; the word `get` literally precedes the closure. > _______________________________________________ > swift-evolution mailing list > swift-evolution@swift.org > https://lists.swift.org/mailman/listinfo/swift-evolution >
_______________________________________________ swift-evolution mailing list swift-evolution@swift.org https://lists.swift.org/mailman/listinfo/swift-evolution