On Sat, 7 Oct 2017 07:48:08 +0100, <swift-evolution-requ...@swift.org> wrote:
> So it would be: > > func() -> @discardable Bool { } > > Rather than: > > @discardableResult func() -> Bool { } > i'd say: func foo() -> discardable Bool { ... } if we were starting from scratch It could be even better if someone could perhaps find a shorter word that > is a synonym for the word "discardable", that would be as explicit in > intent as the word "discardable" is in such context, yet be written with > fewer characters. > Mike
_______________________________________________ swift-evolution mailing list swift-evolution@swift.org https://lists.swift.org/mailman/listinfo/swift-evolution