> On Nov 13, 2017, at 10:11 AM, Shawn Erickson via swift-evolution 
> <swift-evolution@swift.org> wrote:
> 
> 
> On Mon, Nov 13, 2017 at 10:02 AM C. Keith Ray via swift-evolution 
> <swift-evolution@swift.org <mailto:swift-evolution@swift.org>> wrote:
> 
> You said "compact" removes nil values, so I'd name it "removeNils".
> 
> Terms like "ignoring" and "skipping".

Keep in mind that this does *slightly* more than just remove nils—it also 
removes a level of optionality so that it isn't *possible* for there to be nils 
anymore. It's the difference between `if let foo = foo` and `if foo != nil`.

-- 
Brent Royal-Gordon
Architechies

_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution

Reply via email to