On Wed, Dec 20, 2017 at 10:01 PM, Xiaodi Wu via swift-evolution <
swift-evolution@swift.org> wrote:
> I have been doing the unkosher thing of using these underscored attributes
> and would very much like to see these formalized.
> My one bikeshedding issue here is the name @abiPublic, which smells too
> much like fileprivate in my subjective opinion. A more concrete objection
> here is the very much non-ideal juxtaposition of two different access
> modifier terms in the "@abiPublic internal" spelling. It would seem to me
> that "@abi" would suffice instead. Indeed, the fact that it's an
> "interface" implies a certain level of visibility, which in my view is more
> precise than coopting the term "public"--that term in turn has an
> established meaning in Swift that, by construction, an "@abiPublic
> internal" method does not fulfill.

Alternatively, since the “@abiPublic” attribute allows objects to be used
by inlined code, why not spell it “@inlinable”?

swift-evolution mailing list

Reply via email to