> On Jan 12, 2018, at 12:15 AM, Chris Eidhof via swift-evolution 
> <swift-evolution@swift.org> wrote:
> 
> Hey SE!
> 
> When we have a bunch of nested structs:
> 
>     struct Sample {
>         var bar: Bar
>     }
>     
>     struct Bar {
>         var show: Bool
>     }
>     
>     var foo = Sample(bar: Bar(show: false))
> 
> It can be repetitive to toggle a deeply nested boolean:
> 
>     foo.bar.show = !foo.bar.show // duplication
> 
> I sometimes add a `toggle` extension on `Bool`
> 
>     extension Bool {
>         mutating func toggle() {
>             self = !self
>         }
>     }
> 
> This allows you to write the same code without duplication, and makes the 
> intent clearer:
> 
>     foo.bar.show.toggle()

I like it!

> In other languages, I don't think the `toggle` would make as much sense, but 
> the mutable self makes this very useful.
> 
> After I posted it on Twitter, it turns out I'm not the only one: 
> https://twitter.com/PublicExtension/status/730434956376346624
> 
> I would have gone straight to a proposal, but I think we can do some 
> bikeshedding about the name of `toggle`?

Another verb that could work is `invert`.

The `!` operator that does this is the negation operator, but I think `negate` 
could sound to some like "make this false" rather than toggling. 

Nate
_______________________________________________
swift-evolution mailing list
swift-evolution@swift.org
https://lists.swift.org/mailman/listinfo/swift-evolution

Reply via email to