Can't get recent systemd-git to build on Arch, likely due to the bus error
changes:

$ make -j1 V=1
make --no-print-directory all-recursive
Making all in .
/bin/sh ./libtool  --tag=CC   --mode=link gcc -std=gnu99 -pipe -Wall
-Wextra -Wno-inline -Wundef -Wformat=2 -Wformat-security
-Wformat-nonliteral -Wlogical-op -Wsign-compare -Wmissing-include-dirs
-Wold-style-definition -Wpointer-arith -Winit-self
-Wdeclaration-after-statement -Wfloat-equal -Wsuggest-attribute=noreturn
-Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls
-Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels
-Wstrict-aliasing=2 -Wwrite-strings -Wno-long-long -Wno-overlength-strings
-Wno-unused-parameter -Wno-missing-field-initializers -Wno-unused-result
-Werror=overflow -Wdate-time -Wnested-externs -ffast-math -fno-common
-fdiagnostics-show-option -fno-strict-aliasing -fvisibility=hidden
-ffunction-sections -fdata-sections -fstack-protector
-fstack-protector-strong -fPIE --param=ssp-buffer-size=4 -flto
-ffat-lto-objects   -fvisibility=default -I/usr/include/python3.4m
 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong
--param=ssp-buffer-size=4 -Wno-error -Wl,--as-needed -Wl,--no-undefined
-Wl,--gc-sections -Wl,-z,relro -Wl,-z,now -pie -Wl,-fuse-ld=gold   -shared
-module -avoid-version -Wl,-O1,--sort-common,--as-needed,-z,relro -o
login.la -rpath /usr/lib/python3.4/site-packages/systemd
src/python-systemd/login_la-login.lo src/python-systemd/login_la-pyutil.lo
-lpython3.4m  libsystemd-shared.la libsystemd.la -ldw -ldl
libtool: link: gcc -shared  -fPIC -DPIC
 src/python-systemd/.libs/login_la-login.o
src/python-systemd/.libs/login_la-pyutil.o  -Wl,--whole-archive
./.libs/libsystemd-shared.a -Wl,--no-whole-archive  -Wl,-rpath
-Wl,/home/grawity/pkg/aur/systemd-git/src/systemd/.libs -lpython3.4m
./.libs/libsystemd.so -lcap -lrt -llzma -lgcrypt -lgpg-error -lresolv -ldw
-ldl  -fstack-protector -fstack-protector-strong -flto -march=x86-64
-mtune=generic -O2 -fstack-protector-strong -Wl,--as-needed
-Wl,--no-undefined -Wl,--gc-sections -Wl,-z -Wl,relro -Wl,-z -Wl,now
-Wl,-fuse-ld=gold -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z
-Wl,relro   -pthread -Wl,-soname -Wl,login.so -o .libs/login.so
/tmp/ccvBkiub.ltrans0.ltrans.o:ccvBkiub.ltrans0.o:standard_errors_copy_2:
error: undefined reference to 'standard_errors'
collect2: error: ld returned 1 exit status
Makefile:10448: recipe for target 'login.la' failed
make[2]: *** [login.la] Error 1
Makefile:17825: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
Makefile:9066: recipe for target 'all' failed
make: *** [all] Error 2

Meanwhile, I'm using 217-595-g8b5e2af. It seems that, regardless of their
actual state, `systemctl status` now always shows all units as
runtime-enabled:

> Loaded: loaded (/usr/lib/systemd/system/<foo>.service; enabled-runtime;
vendor preset: enabled)

`systemctl is-enabled` shows the correct information. Is this a bug or does
`systemctl status` simply show a different parameter now?

-- 
Mantas Mikulėnas <graw...@gmail.com>
_______________________________________________
systemd-devel mailing list
systemd-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/systemd-devel

Reply via email to