On 12/02/2018 18:02, Rick Coloccia wrote:
Hi,

I've been using tac_plus for years, never any issues. Thanks for it!

Last week we replaced an older centos box with a cenos7 box. I installed tac_plus using an rpm from pbone.net.

I could not get it to work to save my life. I messed around with the tacplus config, the pam config, no luck at all. I was at witt's end.

I started the process manually with a bunch of -d from the cli and it lit right up. Then I killed it, started it without all the -d from the cli and it still worked.

So now I'm confused. When I allow the binary to start using the scripts it won't function, when I start it from cli it works fine.

when I run:

[root@localhost log]# ps auxw | grep tac_
root     16163  0.0  0.0  26000   528 ?        S    10:30   0:00 /usr/bin/tac_plus -C /etc/tac_plus.conf

and when I run:

[root@localhost log]# netstat -anp | grep tac_
tcp        0      0 0.0.0.0:49 0.0.0.0:*               LISTEN 16163/tac_plus
unix  2      [ ]         DGRAM                    6079166 16163/tac_plus


The output is the same regardless of whether I started via cli or scripts.


I just don't know where to go from here. Looking for suggestions.

"scripts" are unlikely to work on Centos 7 as that uses systemd not SysVInit. I'm guessing your rpm was built for a much older Centos and quite likely is getting the log location wrong, or doesn't account for permissions. Just starting the daemon on the cli does the right thing and there's no interfering script messing up the works


--
Alan McKinnon
alan.mckin...@gmail.com

_______________________________________________
tac_plus mailing list
tac_plus@shrubbery.net
http://www.shrubbery.net/mailman/listinfo/tac_plus

Reply via email to