On 02/09/18 02:47, Christos Zoulas wrote:
In article <p5g2an$qui$1...@blaine.gmane.org>,
Valery Ushakov <u...@stderr.spb.ru> wrote:
Kamil Rytarowski <n...@gmx.com> wrote:
I propose to add a definition of _UC_MACHINE_BP() across the ports in
BP stands for Base Pointer / Frame Pointer.
Please, s/BP/FP/. "Frame pointer" is an esablished name and several
assemblers use "fp" as a register name/alias (e.g. vax, sparc); "base
pointer" it too vague; clashes with "breakpoint".
Yes, FP is better alhough it clashes with Floating Point :-)
_REG_FP is defined by at least arm and vax.