On Fri, May 6, 2011 at 7:52 PM, Matthew Dempsky <matt...@dempsky.org> wrote:
> If you have a sili(4) or ahci(4), I'd appreciate a quick test of the
> diff below.  As long as you can still mount your disks without
> panicking, then it worked. :)
>
> One test for each is sufficient, so please reply to the list to save
> others from redundant effort.

It works on ahci(4):

OpenBSD 4.9-current (GENERIC.MP) #79: Fri May  6 21:38:57 CEST 2011
    r...@kronenbourg.panam.brimbelle.org:/usr/src/sys/arch/amd64/compile/GENE
RIC.MP
real mem = 4292280320 (4093MB)
avail mem = 4163969024 (3971MB)
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.6 @ 0xf0710 (68 entries)
bios0: vendor American Megatrends Inc. version "2003" date 12/14/2010
bios0: ASUSTeK Computer INC. P7P55D
acpi0 at bios0: rev 2
acpi0: sleep states S0 S1 S3 S4 S5
acpi0: tables DSDT FACP APIC MCFG OEMB HPET DMAR ASPT OSFR
acpi0: wakeup devices P0P4(S4) BR1E(S4) UAR1(S4) PS2K(S4) PS2M(S4)
EUSB(S4) USB0(S4) USB1(S4) USB2(S4) USB3(S4) USBE(S4) USB4(S4)
USB5(S4) USB6(S4) BR21(S4) BR22(S4) BR23(S4) P0P1(S4) P0P3(S4)
P0P5(S4) P0P6(S4) USB8(S4) BR20(S4) BR24(S4) BR25(S4) BR26(S4)
BR27(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM) i5 CPU 660 @ 3.33GHz, 4017.02 MHz
cpu0:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,PCLMUL,MWAIT,DS-CPL,VMX,SMX,ES
T,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,POPCNT,AES,NXE,LONG
cpu0: 256KB 64b/line 8-way L2 cache
cpu0: apic clock running at 160MHz
cpu1 at mainbus0: apid 4 (application processor)
cpu1: Intel(R) Core(TM) i5 CPU 660 @ 3.33GHz, 4016.54 MHz
cpu1:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,PCLMUL,MWAIT,DS-CPL,VMX,SMX,ES
T,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,POPCNT,AES,NXE,LONG
cpu1: 256KB 64b/line 8-way L2 cache
cpu2 at mainbus0: apid 1 (application processor)
cpu2: Intel(R) Core(TM) i5 CPU 660 @ 3.33GHz, 4016.54 MHz
cpu2:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,PCLMUL,MWAIT,DS-CPL,VMX,SMX,ES
T,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,POPCNT,AES,NXE,LONG
cpu2: 256KB 64b/line 8-way L2 cache
cpu3 at mainbus0: apid 5 (application processor)
cpu3: Intel(R) Core(TM) i5 CPU 660 @ 3.33GHz, 4016.54 MHz
cpu3:
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUS
H,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,PCLMUL,MWAIT,DS-CPL,VMX,SMX,ES
T,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,POPCNT,AES,NXE,LONG
cpu3: 256KB 64b/line 8-way L2 cache
ioapic0 at mainbus0: apid 6 pa 0xfec00000, version 20, 24 pins
ioapic0: misconfigured as apic 1, remapped to apid 6
acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
acpihpet0 at acpi0: 14318179 Hz
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus 7 (BR1E)
acpiprt2 at acpi0: bus -1 (BR21)
acpiprt3 at acpi0: bus -1 (BR22)
acpiprt4 at acpi0: bus -1 (BR23)
acpiprt5 at acpi0: bus 1 (P0P1)
acpiprt6 at acpi0: bus -1 (P0P3)
acpiprt7 at acpi0: bus -1 (P0P5)
acpiprt8 at acpi0: bus -1 (P0P6)
acpiprt9 at acpi0: bus 6 (BR20)
acpiprt10 at acpi0: bus 5 (BR24)
acpiprt11 at acpi0: bus 4 (BR25)
acpiprt12 at acpi0: bus 3 (BR26)
acpiprt13 at acpi0: bus 2 (BR27)
acpiec0 at acpi0
acpicpu0 at acpi0
acpicpu1 at acpi0
acpicpu2 at acpi0
acpicpu3 at acpi0
aibs0 at acpi0: GGRP GITM SITM
acpibtn0 at acpi0: PWRB
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel Core Host" rev 0x12
ppb0 at pci0 dev 1 function 0 "Intel Core PCIE" rev 0x12: apic 6 int 16
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "ATI Radeon HD 4670" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
radeondrm0 at vga1: apic 6 int 16
drm0 at radeondrm0
azalia0 at pci1 dev 0 function 1 "ATI Radeon HD 4000 HD Audio" rev
0x00: apic 6 int 17
azalia0: no supported codecs
ehci0 at pci0 dev 26 function 0 "Intel 3400 USB" rev 0x06: apic 6 int 16
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia1 at pci0 dev 27 function 0 "Intel 3400 HD Audio" rev 0x06: apic 6 int
22
azalia1: codecs: VIA/0x4441
audio0 at azalia1
ppb1 at pci0 dev 28 function 0 "Intel 3400 PCIE" rev 0x06: apic 6 int 17
pci2 at ppb1 bus 6
ppb2 at pci0 dev 28 function 4 "Intel 3400 PCIE" rev 0x06: apic 6 int 17
pci3 at ppb2 bus 5
ppb3 at pci0 dev 28 function 5 "Intel 3400 PCIE" rev 0x06: apic 6 int 16
pci4 at ppb3 bus 4
ppb4 at pci0 dev 28 function 6 "Intel 3400 PCIE" rev 0x06: apic 6 int 18
pci5 at ppb4 bus 3
jmb0 at pci5 dev 0 function 0 "JMicron JMB363 IDE/SATA" rev 0x03
ahci0 at jmb0: apic 6 int 18, AHCI 1.0
scsibus0 at ahci0: 32 targets
sd0 at scsibus0 targ 1 lun 0: <ATA, SAMSUNG HD103UJ, 1AA0> SCSI3
0/direct fixed naa.50000f00070c0776
sd0: 953869MB, 512 bytes/sec, 1953525168 sec total
jmb1 at pci5 dev 0 function 1 "JMicron JMB363 IDE/SATA" rev 0x03
pciide0 at jmb1: DMA, channel 0 wired to native-PCI, channel 1 wired
to native-PCI
pciide0: using apic 6 int 19 for native-PCI interrupt
atapiscsi0 at pciide0 channel 0 drive 0
scsibus1 at atapiscsi0: 2 targets
cd0 at scsibus1 targ 0 lun 0: <PHILIPS, DVDR1628P1, Q1.1> ATAPI
5/cdrom removable
cd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
pciide0: channel 1 disabled (no drives)
ppb5 at pci0 dev 28 function 7 "Intel 3400 PCIE" rev 0x06: apic 6 int 19
pci6 at ppb5 bus 2
re0 at pci6 dev 0 function 0 "Realtek 8168" rev 0x03: RTL8168D/8111D
(0x2800), apic 6 int 19, address 48:5b:39:46:e1:d5
rgephy0 at re0 phy 7: RTL8169S/8110S PHY, rev. 2
ehci1 at pci0 dev 29 function 0 "Intel 3400 USB" rev 0x06: apic 6 int 23
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb6 at pci0 dev 30 function 0 "Intel 82801BA Hub-to-PCI" rev 0xa6
pci7 at ppb6 bus 7
pcib0 at pci0 dev 31 function 0 "Intel P55 LPC" rev 0x06
ahci1 at pci0 dev 31 function 2 "Intel 3400 AHCI" rev 0x06: apic 6 int
21, AHCI 1.3
scsibus2 at ahci1: 32 targets
sd1 at scsibus2 targ 0 lun 0: <ATA, C300-CTFDDAC064M, 0002> SCSI3
0/direct fixed naa.500a075102fbf57c
sd1: 61057MB, 512 bytes/sec, 125045424 sec total
sd2 at scsibus2 targ 1 lun 0: <ATA, WDC WD10EALS-002, 05.0> SCSI3
0/direct fixed naa.50014ee2af255ab6
sd2: 953869MB, 512 bytes/sec, 1953525168 sec total
ichiic0 at pci0 dev 31 function 3 "Intel 3400 SMBus" rev 0x06: apic 6 int 18
iic0 at ichiic0
spdmem0 at iic0 addr 0x50: 2GB DDR3 SDRAM PC3-10600
spdmem1 at iic0 addr 0x52: 2GB DDR3 SDRAM PC3-10600
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
lm0 at isa0 port 0x290/8: W83627DHG
mtrr: Pentium Pro MTRR support
uhub2 at uhub0 port 1 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
uhub3 at uhub1 port 1 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
uhidev0 at uhub3 port 7 configuration 1 interface 0 "Logitech USB-PS/2
Optical Mouse" rev 2.00/22.00 addr 3
uhidev0: iclass 3/1
ums0 at uhidev0: 8 buttons, Z dir
wsmouse0 at ums0 mux 0
uvideo0 at uhub3 port 8 configuration 1 interface 0 "Logitech QuickCam
Pro 9000" rev 2.00/0.08 addr 4
video0 at uvideo0
uaudio0 at uhub3 port 8 configuration 1 interface 2 "Logitech QuickCam
Pro 9000" rev 2.00/0.08 addr 4
uaudio0: audio rev 1.00, 2 mixer controls
audio1 at uaudio0
vscsi0 at root
scsibus3 at vscsi0: 256 targets
softraid0 at root
root on sd1a swap on sd1b dump on sd1b



--
Mattieu Baptiste
"/earth is 102% full ... please delete anyone you can."

Reply via email to