On Fri, 23 Sep 2011, David Coppa wrote:

> On Mon, 12 Sep 2011, Owain Ainsworth wrote:
> 
> > On Mon, Sep 12, 2011 at 12:31:46AM +0100, Owain Ainsworth wrote:
> > > I've been sitting on various stages of this update for far too long,
> > > about time i sent it out.
> > > 
> > > This updates the rendering code in the in-tree intel driver to much more
> > > recent versions of the upstream intel driver, while retaining user
> > > modesetting code (backporting work by me as well as a few openbsd
> > > specific changes). This fixes many bugs and provides a large speed
> > > improvement (especially text rendering) on 965 and above chipsets.
> > > 
> > > A few bugfixes from kettenis@ are also present fixing some nagging
> > > issues.
> > > 
> > > This is a prerequisite for support for sandybridge chipsets so it would
> > > be good to get it into the tree soon. Testing would be much appreciated.
> > > Instructions follow:
> > > 
> > > Download the tarball at http://xenocara.org/src/intel_update.tgz
> > > 
> > > move /usr/xenocara/driver/xf86-video-intel out of the way and untar the
> > > tgz from xenocara/drivers
> > > 
> > > cd xf86-video-intel
> > > make -f Makefile.bsd-wrapper obj
> > > make -f Makefile.bsd-wrapper build
> > > 
> > > Please let me know if you find any issues, otherwise reports of which
> > > hardware this was testing on to me privately please.
> > 
> > The driver on the web has been updated to not have the sandybridge
> > pciids set to match.
> 
> The occasional "PGTBL_ER... resetting gpu: done!" message from the kernel
> I was experiencing in the past seems to have disappeared definitely...

Pardon me, It was a tough day... Forgot to add the relevant informations:

OpenBSD 5.0-current (GENERIC.MP) #1: Mon Sep 19 19:40:12 CEST 2011
    dco...@latitude.dacolab.dom:/usr/src/sys/arch/amd64/compile/GENERIC.MP
real mem = 4283801600 (4085MB)
avail mem = 4155645952 (3963MB)
mainbus0 at root
bios0 at mainbus0: SMBIOS rev. 2.4 @ 0xf68e0 (62 entries)
bios0: vendor Dell Inc. version "A17" date 01/04/2010
bios0: Dell Inc. Latitude D630
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP HPET APIC ASF! MCFG TCPA SLIC SSDT
acpi0: wakeup devices PCI0(S5) PCIE(S4) USB1(S0) USB2(S0) USB3(S0) USB4(S0) 
USB5(S0) EHC2(S0) EHCI(S0) AZAL(S3) RP01(S3) RP02(S4) RP03(S3) RP04(S3) 
RP05(S3) RP06(S5) LID_(S3) PBTN(S4)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: Intel(R) Core(TM)2 Duo CPU T7250 @ 2.00GHz, 1995.32 MHz
cpu0: 
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,NXE,LONG
cpu0: 2MB 64b/line 8-way L2 cache
cpu0: apic clock running at 199MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM)2 Duo CPU T7250 @ 2.00GHz, 1995.00 MHz
cpu1: 
FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,NXE,LONG
cpu1: 2MB 64b/line 8-way L2 cache
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
ioapic0: misconfigured as apic 0, remapped to apid 2
acpimcfg0 at acpi0 addr 0xf8000000, bus 0-63
acpiprt0 at acpi0: bus 3 (PCIE)
acpiprt1 at acpi0: bus -1 (AGP_)
acpiprt2 at acpi0: bus 11 (RP01)
acpiprt3 at acpi0: bus 12 (RP02)
acpiprt4 at acpi0: bus -1 (RP03)
acpiprt5 at acpi0: bus -1 (RP04)
acpiprt6 at acpi0: bus -1 (RP05)
acpiprt7 at acpi0: bus 9 (RP06)
acpiprt8 at acpi0: bus 0 (PCI0)
acpicpu0 at acpi0: C3, C2, C1, PSS
acpicpu1 at acpi0: C3, C2, C1, PSS
acpitz0 at acpi0: critical temperature is 99 degC
acpibtn0 at acpi0: LID_
acpibtn1 at acpi0: PBTN
acpibtn2 at acpi0: SBTN
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT0 not present
acpibat1 at acpi0: BAT1 not present
acpidock0 at acpi0: GDCK not docked (0)
acpivideo0 at acpi0: VID_
acpivideo1 at acpi0: VID_
acpivideo2 at acpi0: VID2
cpu0: Enhanced SpeedStep 1995 MHz: speeds: 2001, 2000, 1600, 1200, 800 MHz
pci0 at mainbus0 bus 0
pchb0 at pci0 dev 0 function 0 "Intel GM965 Host" rev 0x0c
vga1 at pci0 dev 2 function 0 "Intel GM965 Video" rev 0x0c
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
intagp0 at vga1
agp0 at intagp0: aperture at 0xe0000000, size 0x10000000
inteldrm0 at vga1: apic 2 int 16
drm0 at inteldrm0
"Intel GM965 Video" rev 0x0c at pci0 dev 2 function 1 not configured
uhci0 at pci0 dev 26 function 0 "Intel 82801H USB" rev 0x02: apic 2 int 20
uhci1 at pci0 dev 26 function 1 "Intel 82801H USB" rev 0x02: apic 2 int 21
ehci0 at pci0 dev 26 function 7 "Intel 82801H USB" rev 0x02: apic 2 int 22
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel 82801H HD Audio" rev 0x02: msi
azalia0: codecs: Sigmatel STAC9205X
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 82801H PCIE" rev 0x02: msi
pci1 at ppb0 bus 11
ppb1 at pci0 dev 28 function 1 "Intel 82801H PCIE" rev 0x02: msi
pci2 at ppb1 bus 12
ral0 at pci2 dev 0 function 0 "Ralink RT2890" rev 0x00: apic 2 int 17, address 
00:0d:f0:7d:ba:64
ral0: MAC/BBP RT2860 (rev 0x0102), RF RT2820 (MIMO 2T3R)
ppb2 at pci0 dev 28 function 5 "Intel 82801H PCIE" rev 0x02: msi
pci3 at ppb2 bus 9
bge0 at pci3 dev 0 function 0 "Broadcom BCM5755M" rev 0x02, BCM5755 A2 
(0xa002): apic 2 int 17, address 00:1c:23:36:a8:89
brgphy0 at bge0 phy 1: BCM5755 10/100/1000baseT PHY, rev. 0
uhci2 at pci0 dev 29 function 0 "Intel 82801H USB" rev 0x02: apic 2 int 20
uhci3 at pci0 dev 29 function 1 "Intel 82801H USB" rev 0x02: apic 2 int 21
uhci4 at pci0 dev 29 function 2 "Intel 82801H USB" rev 0x02: apic 2 int 22
ehci1 at pci0 dev 29 function 7 "Intel 82801H USB" rev 0x02: apic 2 int 20
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb3 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xf2
pci4 at ppb3 bus 3
cbb0 at pci4 dev 1 function 0 "O2 Micro OZ711EZ1 CardBus" rev 0x21: apic 2 int 
19
"O2 Micro Firewire" rev 0x02 at pci4 dev 1 function 4 not configured
cardslot0 at cbb0 slot 0 flags 0
cardbus0 at cardslot0: bus 4 device 0 cacheline 0x0, lattimer 0x20
pcmcia0 at cardslot0
pcib0 at pci0 dev 31 function 0 "Intel 82801HBM LPC" rev 0x02
pciide0 at pci0 dev 31 function 1 "Intel 82801HBM IDE" rev 0x02: DMA, channel 0 
configured to compatibility, channel 1 configured to compatibility
atapiscsi0 at pciide0 channel 0 drive 0
scsibus0 at atapiscsi0: 2 targets
cd0 at scsibus0 targ 0 lun 0: <Optiarc, DVD+-RW AD-5560A, DD11> ATAPI 5/cdrom 
removable
cd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
pciide0: channel 1 ignored (disabled)
ahci0 at pci0 dev 31 function 2 "Intel 82801HBM AHCI" rev 0x02: msi, AHCI 1.1
ahci0: PHY offline on port 2
scsibus1 at ahci0: 32 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, TOSHIBA MK1637GS, DL03> SCSI3 0/direct 
fixed t10.ATA_TOSHIBA_MK1637GSX_579FF3LRS
sd0: 152627MB, 512 bytes/sector, 312581808 sectors
ichiic0 at pci0 dev 31 function 3 "Intel 82801H SMBus" rev 0x02: SMI
iic0 at ichiic0
usb2 at uhci0: USB revision 1.0
uhub2 at usb2 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb3 at uhci1: USB revision 1.0
uhub3 at usb3 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb4 at uhci2: USB revision 1.0
uhub4 at usb4 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb5 at uhci3: USB revision 1.0
uhub5 at usb5 "Intel UHCI root hub" rev 1.00/1.00 addr 1
usb6 at uhci4: USB revision 1.0
uhub6 at usb6 "Intel UHCI root hub" rev 1.00/1.00 addr 1
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
mtrr: Pentium Pro MTRR support
umsm0 at uhub3 port 2 configuration 1 interface 0 "Novatel Wireless Novatel 
Wireless HSDPA Modem" rev 1.10/0.00 addr 2
ucom0 at umsm0
umsm1 at uhub3 port 2 configuration 1 interface 1 "Novatel Wireless Novatel 
Wireless HSDPA Modem" rev 1.10/0.00 addr 2
ucom1 at umsm1
umsm2 at uhub3 port 2 configuration 1 interface 2 "Novatel Wireless Novatel 
Wireless HSDPA Modem" rev 1.10/0.00 addr 2
ucom2 at umsm2
umsm3 at uhub3 port 2 configuration 1 interface 3 "Novatel Wireless Novatel 
Wireless HSDPA Modem" rev 1.10/0.00 addr 2
ucom3 at umsm3
uhidev0 at uhub4 port 2 configuration 1 interface 0 "Microsoft Compact Optical 
Mouse 500" rev 1.10/1.00 addr 2
uhidev0: iclass 3/1
ums0 at uhidev0: 3 buttons, Z dir
wsmouse1 at ums0 mux 0
uhub7 at uhub6 port 1 "vendor 0x0b97 product 0x7761" rev 1.10/1.10 addr 2
ugen0 at uhub7 port 2 "O2 O2Micro CCID SC Reader" rev 1.10/1.10 addr 3
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
scsibus3 at softraid0: 256 targets
root on sd0a (c2518fac8c297e05.a) swap on sd0b dump on sd0b
sd1 at scsibus3 targ 1 lun 0: <OPENBSD, SR CRYPTO, 005> SCSI2 0/direct fixed
sd1: 147251MB, 512 bytes/sector, 301571873 sectors

Reply via email to