>Not sure if touching all error messages for __func__ is worth it or just
>too much churn in the end.

He already converted some so I don't see a reason to not introduce at least
that diff. If someone comes across something, he could just fix it then and
there if this issue is well-known.

On Tue, Mar 13, 2018 at 1:33 PM, Klemens Nanni <k...@openbsd.org> wrote:

> On Tue, Mar 13, 2018 at 04:39:16PM +0800, Michael W. Bombardieri wrote:
> > Some errors and warnings printed by ksh have the function name
> > prefixed. __func__ could be used here instead of hard-coding
> > the name. The names are wrong for tty_init(), j_set_async(),
> > j_change(), x_file_glob() and c_ulimit() afaics.
> Wrong error messages should definitely be corrected, although I'd either
> fix them literally or use __func__ consistently. This diff would
> introduce the macro for only a handful of functions while leaving the
> vast majority names untouched.
>
> Not sure if touching all error messages for __func__ is worth it or just
> too much churn in the end.
>
>


-- 
Best Regards,
Bobby

Reply via email to