Hey Tobias, On Tue, May 26, 2020 at 5:28 AM Tobias Heider <tobias.hei...@stusta.de> wrote: > > + if (((SIZE_MAX - size) / sizeof(struct wg_aip_io)) < sc->sc_aip_num) > > + goto error; > > I still think those two should return an error. 'goto error' is misleading as > it doesn't actually set ret != 0. 'error' should probably be renamed > to 'cleanup' to avoid confusion and ret should be set to ERANGE .
I'll change the label name to be more clear; I agree "error" is misleading. Returning ERANGE wouldn't be correct though; we still want the struct to be copied back to the user so that they can use the information in it to optionally try again (optionally, because maybe they don't care about info) with a different buffer size.