On Tue, 2016-10-11 at 09:56 +0200, Joachim Backes wrote:
> Hi testers,
> I'm trying to install the F24 version of VirtualBox in F25 because no 
> F25 version is available
> Anybody tried this and was successful?
> I'm experiencing this error:
> sudo dnf install VirtualBox-5.1-5.1.6_110634_fedora24-1.x86_64.rpm
> Last metadata expiration check: 3:04:28 ago on Tue Oct 11 06:49:21 2016.
> Error: *nothing provides libvpx.so.3()(64bit)* needed by 
> VirtualBox-5.1-5.1.6_110634_fedora24-1.x86_64

That's happening because there is no libvpx.so.3 in F25, obviously.

It looks like F25 has gone from libvpx-1.5.0 (libvpx.so.3) to libvpx-1.6.0

Creating a symlink from /usr/lib64/libvpx.so.3 to /usr/lib64/libvpx.so.4.0.0
might work (if the library api has not changed, or at least the calls needed
have not changed, but there might be symbol naming problems as well).

But really what you need is a VirtualBox package built against the new version,

Alternately you could build the source package of libvpx-1.5.0 on F25, remove
libvpx-1.6.0, and then install the libvpx-1.5.0 and make sure to exclude that
package when updating.

But there are probably other package dependencies requiring libvpx-1.6.0 so it
will quickly get tedious building (and rebuilding) dependencies and excluding
those from updates too.

test mailing list -- test@lists.fedoraproject.org
To unsubscribe send an email to test-le...@lists.fedoraproject.org

Reply via email to