On Sat, Dec 09, 2000 at 10:00:50AM +0100, Thomas Esser wrote:
> Hi Mate,
> 
> I just have noticed, that you have unsuccessfully tried to extend the
> TEXMF list. You did uncomment
>   TEXMF = {$HOMETEXMF,!!$TEXMFLOCAL,!!$TEXMFMAIN,$HOME}
> but you did not comment
>   TEXMF = !!$TEXMFMAIN
> 
> (the same problem for TEXMFDBS I guess).
> 
> In the kpathsea world, the first match wins...

Indeed, this was an error on my part.  So now I copied back the
original texmf.cnf (created by the installation), ran texhash,

# texhash
texhash: Updating /usr/local/teTeX/texmf/ls-R... 
texhash: Updating /var/tmp/texfonts/ls-R... 
texhash: Done.

 but I still get the same errors from xdvi.  The texmf.cnf I am using
is now

http://thales.memphis.edu/~tetex/texmf.cnf.txt

I also have a brand new strace output at 

http://thales.memphis.edu/~tetex/xdvi.strace.out.txt

and I put /usr/local/teTeX/texmf/ls-R on the web as 

http://thales.memphis.edu/~tetex/ls-R.texmf.txt

though I do see 

./fonts/tfm/adobe/bookman:
[...]
pbkl7t.tfm

./fonts/vf/adobe/bookman:
[...]
pbkl7t.vf

in /usr/local/teTeX/texmf/ls-R.

Just in case, I  put /var/tmp/texfonts/ls-R as

http://thales.memphis.edu/~tetex/ls-R.var.txt

Finally, find the output of 

texconfig confall 

as

http://thales.memphis.edu/~tetex/texconfig.confall.txt

I'd like to point out that the problem seems to be a general one: if
instead of bookman, I try to use the times package:

\documentclass{article}
\usepackage{times}
\begin{document}
Hi
\end{document}

I get similar errors:

xdvi try
kpathsea: Running mktexpk --mfmode ljfivemp --bdpi 600 --mag 1+0/600
--dpi 600 ptmr7t
mktexpk: Running mf \mode:=ljfivemp; mag:=1+0/600; nonstopmode; input
ptmr7t
This is METAFONT, Version 2.7182 (Web2C 7.3.1)

kpathsea: Running mktexmf  ptmr7t
! I can't find file `ptmr7t'.
<*> ...mp; mag:=1+0/600; nonstopmode; input ptmr7t
                                                  
Please type another input file name
! Emergency stop.
<*> ...mp; mag:=1+0/600; nonstopmode; input ptmr7t
                                                  
Transcript written on mfput.log.
grep: ptmr7t.log: No such file or directory
mktexpk: `mf \mode:=ljfivemp; mag:=1+0/600; nonstopmode; input ptmr7t'
failed to make ptmr7t.600pk.
kpathsea: Appending font creation commands to missfont.log.
xdvi.bin: Can't find font ptmr7t.600pk
xdvi.bin: Not all pixel files were found

I'd like to emphasize I do not have any problems printing since I have
a PostScript printer.

Thx for any help.  In particular, it would be great if somebody would
try my config on a RH 7.0 system (without a modified kpathsea.a):

mkdir -p /usr/local/teTeX/texmf
tar zxvfp  teTeX-texmf-1.0.tar.gz -C /usr/local/teTeX/texmf
tar zxvf teTeX-src-1.0.tar.gz
cd teTeX-1.0

./configure --disable-multiplatform
sh -c 'make world >world.log 2>&1' &

Finally, let me know if I should take this off the list.

Mate

Reply via email to