Bug Tracker item #3611382, was opened at 2013-04-19 08:36
Message generated for change (Comment added) made by bphinz
You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=1126848&aid=3611382&group_id=254363

Please note that this message will contain a full copy of the comment thread,
including the initial issue submission, for this request,
not just the latest update.
Category: UN*X version
Group: 1.2.X
Status: Open
Resolution: None
Priority: 7
Private: No
Submitted By: Donald A. Cupp Jr. (doncuppjr)
Assigned to: Nobody/Anonymous (nobody)
Summary: Won't compile against gnutls 3.1.9

Initial Comment:
Fails compilation with notice about deprecated functions.

In file included from 
/ts/ports/components/tigervnc/work/src/tigervnc-1.2.0/common/rdr/TLSInStream.cxx:27:0:
/ts/ports/components/tigervnc/work/src/tigervnc-1.2.0/common/rdr/TLSInStream.h:36:53:
 warning: 'gnutls_session' is deprecated [-Wdeprecated-declarations]
/ts/ports/components/tigervnc/work/src/tigervnc-1.2.0/common/rdr/TLSInStream.h:45:20:
 warning: 'gnutls_session' is deprecated (declared at 
/usr/include/gnutls/compat.h:65) [-Wdeprecated-declarations]
/ts/ports/components/tigervnc/work/src/tigervnc-1.2.0/common/rdr/TLSInStream.h:52:66:
 warning: 'gnutls_transport_ptr' is deprecated [-Wdeprecated-declarations]
/ts/ports/components/tigervnc/work/src/tigervnc-1.2.0/common/rdr/TLSInStream.cxx:40:18:
 warning: 'gnutls_transport_ptr' is deprecated [-Wdeprecated-declarations]
/ts/ports/components/tigervnc/work/src/tigervnc-1.2.0/common/rdr/TLSInStream.cxx:
 In function 'ssize_t rdr::gnutls_InStream_pull(gnutls_transport_ptr, void*, 
size_t)':
/ts/ports/components/tigervnc/work/src/tigervnc-1.2.0/common/rdr/TLSInStream.cxx:46:47:
 error: 'gnutls_transport_set_global_errno' was not declared in this scope
/ts/ports/components/tigervnc/work/src/tigervnc-1.2.0/common/rdr/TLSInStream.cxx:56:45:
 error: 'gnutls_transport_set_global_errno' was not declared in this scope
/ts/ports/components/tigervnc/work/src/tigervnc-1.2.0/common/rdr/TLSInStream.cxx:
 At global scope:
/ts/ports/components/tigervnc/work/src/tigervnc-1.2.0/common/rdr/TLSInStream.cxx:63:64:
 warning: 'gnutls_session' is deprecated [-Wdeprecated-declarations]
make[2]: *** [common/rdr/CMakeFiles/rdr.dir/TLSInStream.cxx.o] Error 1


----------------------------------------------------------------------

Comment By: Brian Hinz (bphinz)
Date: 2013-04-28 09:37

Message:
I believe that this was fixed in the trunk last year (see r4922, which was
post-1.2.0).

-brian

----------------------------------------------------------------------

Comment By: Donald A. Cupp Jr. (doncuppjr)
Date: 2013-04-19 09:35

Message:
This is actually an error about the function 

gnutls_transport_set_global_errno()

This function has been removed from gnutls 3.0 and on. You might need to
replace it with 
gnutls_transport_set_errno(), but you will need to know the session to set
the error for, as it's not global.

----------------------------------------------------------------------

You can respond by visiting: 
https://sourceforge.net/tracker/?func=detail&atid=1126848&aid=3611382&group_id=254363

------------------------------------------------------------------------------
Try New Relic Now & We'll Send You this Cool Shirt
New Relic is the only SaaS-based application performance monitoring service 
that delivers powerful full stack analytics. Optimize and monitor your
browser, app, & servers with just a few lines of code. Try New Relic
and get this awesome Nerd Life shirt! http://p.sf.net/sfu/newrelic_d2d_apr
_______________________________________________
Tigervnc-devel mailing list
Tigervnc-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/tigervnc-devel

Reply via email to