I do not think load on network was any higher than usual for this system (max 
700mbit/sec of inbound video multicast on same interface)
Both nodes saw same error and was running same kernel.

After reboot, the messages went away.

tipc-config was ran right before this, by a script trying to set network ID and 
tipc addresses. This would have failed as the links were already configured.
(And no we have not yet switched to use “ip tipc” command, as we have to still 
work on some older kernels too).

From: Jon Maloy [mailto:ma...@donjonn.com]
Sent: Wednesday, September 21, 2016 3:01 AM
To: Rune Torgersen; tipc-discussion@lists.sourceforge.net
Subject: Re: [tipc-discussion] Strange TIPC error

Hi Rune,
It means that a link is reset after having tried to retransmit the same packet 
> 100 times. When we have seen this before it has normally been an indication 
that the (very short) link monitoring messages still go through, and that there 
is something wrong with the packet being retransmitted. It cannot be the MTU, 
since the first packet is only 265 bytes long, and as far as I can see the 
source address is also ok.

Are you running the same kernel version on node 1.1.2? Do you have high load on 
on the network when this happens? If it is repeatable, maybe you could provide 
a wireshark dump?


De : Rune Torgersen <ru...@innovsys.com<mailto:ru...@innovsys.com>>
À : 
Envoyé le : mardi 20 Septembre 2016 17h44
Objet : [tipc-discussion] Strange TIPC error

Anybody know what this means?
(Running Ubuntu 4.4.0-31 kernel)

[3706037.493994] Retransmission failure on link <1.1.1:eth0-1.1.2:eth0>
[3706037.494000] Resetting link  Link <1.1.1:eth0-1.1.2:eth0> state e
[3706037.494002] XMTQ: 27 [45216-45242], BKLGQ: 0, SNDNX: 45243, RCVNX: 36674
[3706037.494004] Failed msg: usr 0, typ 2, len 265, err 0
[3706037.494005] sqno 45216, prev: 1001001, src: 1001001
[3706328.908044] Retransmission failure on link <1.1.1:eth0-1.1.2:eth0>
[3706328.908048] Resetting link  Link <1.1.1:eth0-1.1.2:eth0> state e
[3706328.908049] XMTQ: 44 [649-692], BKLGQ: 0, SNDNX: 693, RCVNX: 893
[3706328.908050] Failed msg: usr 12, typ 1, len 1460, err 0
[3706328.908051] sqno 649, prev: 1001001, src: 1001001

tipc-discussion mailing list

tipc-discussion mailing list

Reply via email to