Hi all,

I am experiencing difficulties with port 8005. It crashes
with a BindException after trying to start it.

        OS:  SunOS 5.9
        www2# java -showversion
        java version "1.4.0_03"
        Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.0_03-b04)
        Java HotSpot(TM) Client VM (build 1.4.0_03-b04, mixed mode)

I have tried 5 different Tomcat Versions:

        3.3.1a          - Works

        4.1.18          - Crashes
        4.1.27          - Crashes
        5.0.11          - Crashes
        Sun JWSDP 1.2   - Crashes

In all cases after waiting for $CATALINA_HOME/bin/startup.sh quite a while.
I get the following error at  $CATALINA_HOME/logs/catalina.out:

StandardServer.await: create[8005]: java.net.BindException: Cannot assign
requested address
java.net.BindException: Cannot assign requested address
        at java.net.PlainSocketImpl.socketBind(Native Method)
        at java.net.PlainSocketImpl.bind(PlainSocketImpl.java:321)
        at java.net.ServerSocket.bind(ServerSocket.java:308)
        at java.net.ServerSocket.bind(ServerSocket.java:266)
        at java.net.ServerSocket.<init>(ServerSocket.java:182)
        at org.apache.catalina.startup.Catalina.await(Catalina.java:633)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:595)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

I have checked if I have a server using that specific port and
it  doesnīt seem to be the case.

www2# netstat -an | grep 8080

I even tried by changing the port on the server.xml file to another and it
to crash.

The user with which I am trying to start the service is root. I donīt see
it wouldnīt have permission to start it.

I have checked who is the owner of the Tomcat Files, and in all cases it is

www2# ls -la
-rwxr-xr-x   1 root     root         788 Dec 19  2002 startup.sh

Do you have a clue on what is going on here, is there any well known problem

To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to