I have tried to make the QUDT units ontology (pre-loaded) accessible via 
GraphQL and failed...

If I include it into a empty data graph I can traverse and inspect all the 

I can set the search root to be, for example Unit

I then add  statements like this to the graph root object..

  graphql:publicClass qudt:Unit ;
 teamwork:mainClass qudt:Unit ;
  teamwork:rootClass qudt:Unit ;

but the Unit class does not show up as an option the the GraphQL schema:

{ _rootTypeShapes {
} }


  "data": {
    "_rootTypeShapes": []

I also tried loading the file into an ontology, running OWL->SHACL then 
defining the graphqL public classes,  and incuding into the data graph.  
Still navigable and not queryable.

even if i wanted to, I  cannot import the file - it complains about having 
classes defined.

And in the search panel the search class is listed, but it doesnt offer the 
class hierarchy and the search box is greyed out.

I also tried building the lucene indices.

What exactly is the requirement for GraphQL to be enabled? - and can anyone 
provide an example recipe that works to allow query for any or all of the 
various models available in EDG by default.

You received this message because you are subscribed to the Google Groups 
"TopBraid Suite Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to topbraid-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 

Reply via email to