#20333: add descriptor digest to vote and streamline method name
 Reporter:  iwakeh               |          Owner:  karsten
     Type:  enhancement          |         Status:  new
 Priority:  Medium               |      Milestone:  metrics-lib 1.5.0
Component:  Metrics/metrics-lib  |        Version:
 Severity:  Normal               |     Resolution:
 Keywords:                       |  Actual Points:
Parent ID:                       |         Points:
 Reviewer:                       |        Sponsor:

Comment (by iwakeh):

 This could get solved by overloading with an additional parameter for the
 That could also be useful for the sha*Hex methods.  So, it might be good
 to look for other candidates.

 From a developing user point of view I'd rather have these methods named
 the same and prefer a short name.  (Just having "digest()" is worth
 considering, but that is a bigger change.)  It's easier to make an api
 popular when there is a consistent and lean naming scheme.

 Some examples:
 `relayDesc.getDigest()` instead of `relayDesc.getServerDescriptorDigest()`
 `relayDesc.getDigest(Sha256)` instead of
 `micro.getDigest()` instead of `micro.getMicrodescriptorDigest()`

 Of course,  there needs to be a transition and the clients' in Metrics
 products will have to be adapted.

Ticket URL: <https://trac.torproject.org/projects/tor/ticket/20333#comment:3>
Tor Bug Tracker & Wiki <https://trac.torproject.org/>
The Tor Project: anonymity online
tor-bugs mailing list

Reply via email to