commit 774cc32ebea0b08078053a8ea6c5fe3a9d5beea7
Author: Damian Johnson <ata...@torproject.org>
Date:   Mon Aug 7 12:41:52 2017 -0700

    Drop python 2.6 support
    
    Stem still supports python 2.6, and our codebase probably works with it too.
    However, there's still a couple reasons to drop official support...
    
      1. Stem will be dropping python 2.6 support in its 2.x release. Python
         deprecated 2.6 long ago, and there's quite a few hacks in Stem's
         codebase to provide compatibility. Those will be going away.
    
         Not sure when I'll be releasing Stem 2.x, but no double it'll be
         long before Nyx's 3.x major version, so might as well drop
         official 2.6 support now.
    
      2. Python 2.6 packages are no longer available, making compatibility 
testing
         a pita. I've compiled obsolete python versions for testing before,
         and this is a chore I'd like to do without.
---
 web/changelog/index.html | 2 +-
 web/index.html           | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/web/changelog/index.html b/web/changelog/index.html
index de52df5..c95f522 100644
--- a/web/changelog/index.html
+++ b/web/changelog/index.html
@@ -52,7 +52,7 @@
 
       <p>The following are only available within Nyx's <a href="#git">git 
repository</a>.</p>
       <p>From a user perspective little has changed, but this release is 
nothing less than a complete rewrite of our codebase. This adds long overdue 
<b>support for python 3.x</b>, test coverage, and migrate from TorCtl to <a 
href="https://stem.torproject.org/";>Stem</a>.</p>
-      <p>Python 2.5 is no longer supported. Hopefully by now nobody will miss 
it. :P</p>
+      <p>Python 2.5 and 2.6 is no longer supported. Hopefully by now nobody 
will miss it. :P</p>
 
       <br>
 
diff --git a/web/index.html b/web/index.html
index 4910c66..06284ce 100644
--- a/web/index.html
+++ b/web/index.html
@@ -119,7 +119,7 @@
         <li id="python_requirement">
           <span>What Python versions is Nyx compatible with?</span>
           <div class="answer">
-            <p>Nyx works with <b>Python 2.6 and greater</b>, including the 
Python 3.x series.</p>
+            <p>Nyx works with <b>Python 2.7 and greater</b>, including the 
Python 3.x series.</p>
           </div>
         </li>
 



_______________________________________________
tor-commits mailing list
tor-commits@lists.torproject.org
https://lists.torproject.org/cgi-bin/mailman/listinfo/tor-commits

Reply via email to