This is the list of packages that got upgraded:

qtdeclarative5-ubuntu-ui-toolkit-plugin:amd64 
(1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 1.3.2085+16.04.20160831.4)
liboxideqt-qmlplugin:amd64 (1.16.8-0ubuntu0.16.04.1~overlay1, 
1.17.7-0ubuntu0.16.04.1)
mediascanner2.0:amd64 (0.111+16.04.20160526-0ubuntu1, 
0.112+16.04.20160909-0ubuntu1)
unity-schemas:amd64 (7.4.0+16.04.20160801.2-0ubuntu1, 
7.4.0+16.04.20160906-0ubuntu1)
liboxideqtquick0:amd64 (1.16.8-0ubuntu0.16.04.1~overlay1, 
1.17.7-0ubuntu0.16.04.1)
qml-module-ubuntu-test:amd64 (1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 
1.3.2085+16.04.20160831.4)
libtelepathy-qt4-2:amd64 (0.9.6.1-7ubuntu2~xenial, 0.9.6.1-9ubuntu6~xenial)
ubuntu-ui-toolkit-tools:amd64 (1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 
1.3.2085+16.04.20160831.4)
liboxideqtcore0:amd64 (1.16.8-0ubuntu0.16.04.1~overlay1, 
1.17.7-0ubuntu0.16.04.1)
libtelepathy-qt5-0:amd64 (0.9.6.1-7ubuntu2~xenial, 0.9.6.1-9ubuntu6~xenial)
ubuntu-ui-toolkit-autopilot:amd64 
(1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 1.3.2085+16.04.20160831.4)
bamfdaemon:amd64 (0.5.3~bzr0+16.04.20160701-0ubuntu1, 
0.5.3~bzr0+16.04.20160824-0ubuntu1)
libthumbnailer-qt-dev:amd64 (2.4+16.04.20160719-0ubuntu1, 
2.4+16.04.20160825-0ubuntu1)
libsystemd0:amd64 (229-4ubuntu7, 229-4ubuntu8)
libsystemd0:i386 (229-4ubuntu7, 229-4ubuntu8)
adobe-flash-properties-gtk:amd64 (1:20160712.1-0ubuntu0.16.04.1, 
1:20160913.1-0ubuntu0.16.04.1)
thumbnailer-service:amd64 (2.4+16.04.20160719-0ubuntu1, 
2.4+16.04.20160825-0ubuntu1)
gir1.2-click-0.4:amd64 (0.4.43+16.04.20160203-0ubuntu2, 
0.4.45+16.04.20160828.1-0ubuntu1)
qtdeclarative5-ubuntu-download-manager0.1:amd64 (1.3+16.04.20160812.2-0ubuntu1, 
1.3+16.04.20160909.1-0ubuntu1)
ubuntu-app-launch-profiler:amd64 
(1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 1.3.2085+16.04.20160831.4)
click:amd64 (0.4.43+16.04.20160203-0ubuntu2, 0.4.45+16.04.20160828.1-0ubuntu1)
libudm-common1:amd64 (1.3+16.04.20160812.2-0ubuntu1, 
1.3+16.04.20160909.1-0ubuntu1)
udev:amd64 (229-4ubuntu7, 229-4ubuntu8)
libubuntu-download-manager-client1:amd64 (1.3+16.04.20160812.2-0ubuntu1, 
1.3+16.04.20160909.1-0ubuntu1)
libnet-cpp2:amd64 (2.0.0-0ubuntu1, 2.1.0+16.04.20160913.2-0ubuntu1)
unity:amd64 (7.4.0+16.04.20160801.2-0ubuntu1, 7.4.0+16.04.20160906-0ubuntu1)
qml-module-ubuntu-performancemetrics:amd64 
(1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 1.3.2085+16.04.20160831.4)
phablet-tools:amd64 (1.2.1+16.04.20160906-0ubuntu1, 
1.2.1+16.04.20160913-0ubuntu1)
qml-module-ubuntu-mediascanner0.1:amd64 (0.111+16.04.20160526-0ubuntu1, 
0.112+16.04.20160909-0ubuntu1)
qtdeclarative5-ubuntu-mediascanner0.1:amd64 (0.111+16.04.20160526-0ubuntu1, 
0.112+16.04.20160909-0ubuntu1)
libudm-priv-common1:amd64 (1.3+16.04.20160812.2-0ubuntu1, 
1.3+16.04.20160909.1-0ubuntu1)
libudev1:amd64 (229-4ubuntu7, 229-4ubuntu8)
libudev1:i386 (229-4ubuntu7, 229-4ubuntu8)
gtk2-engines-murrine:amd64 (0.98.2-0ubuntu2.1, 0.98.2-0ubuntu2.2)
adobe-flashplugin:amd64 (1:20160712.1-0ubuntu0.16.04.1, 
1:20160913.1-0ubuntu0.16.04.1)
libbamf3-2:amd64 (0.5.3~bzr0+16.04.20160701-0ubuntu1, 
0.5.3~bzr0+16.04.20160824-0ubuntu1)
qtdeclarative5-ubuntu-thumbnailer0.1:amd64 (2.4+16.04.20160719-0ubuntu1, 
2.4+16.04.20160825-0ubuntu1)
ubuntu-ui-toolkit-doc:amd64 (1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 
1.3.2085+16.04.20160831.4)
libnet-cpp-dev:amd64 (2.0.0-0ubuntu1, 2.1.0+16.04.20160913.2-0ubuntu1)
libudev-dev:amd64 (229-4ubuntu7, 229-4ubuntu8)
python3-click-package:amd64 (0.4.43+16.04.20160203-0ubuntu2, 
0.4.45+16.04.20160828.1-0ubuntu1)
click-dev:amd64 (0.4.43+16.04.20160203-0ubuntu2, 
0.4.45+16.04.20160828.1-0ubuntu1)
click-doc:amd64 (0.4.43+16.04.20160203-0ubuntu2, 
0.4.45+16.04.20160828.1-0ubuntu1)
systemd-sysv:amd64 (229-4ubuntu7, 229-4ubuntu8)
unity-services:amd64 (7.4.0+16.04.20160801.2-0ubuntu1, 
7.4.0+16.04.20160906-0ubuntu1)
libunity-core-6.0-9:amd64 (7.4.0+16.04.20160801.2-0ubuntu1, 
7.4.0+16.04.20160906-0ubuntu1)
oxideqt-codecs-extra:amd64 (1.16.8-0ubuntu0.16.04.1~overlay1, 
1.17.7-0ubuntu0.16.04.1)
libpam-systemd:amd64 (229-4ubuntu7, 229-4ubuntu8)
libubuntumetrics5:amd64 (1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 
1.3.2085+16.04.20160831.4)
systemd:amd64 (229-4ubuntu7, 229-4ubuntu8)
libwebkit2gtk-4.0-37:amd64 (2.10.9-1ubuntu1, 2.12.5-0ubuntu0.16.04.1)
qml-module-ubuntu-layouts:amd64 
(1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 1.3.2085+16.04.20160831.4)
mysql-common:amd64 (5.7.13-0ubuntu0.16.04.2, 5.7.15-0ubuntu0.16.04.1)
libmysqlclient20:i386 (5.7.13-0ubuntu0.16.04.2, 5.7.15-0ubuntu0.16.04.1)
libubuntu-download-manager-common1:amd64 (1.3+16.04.20160812.2-0ubuntu1, 
1.3+16.04.20160909.1-0ubuntu1)
libclick-0.4-0:amd64 (0.4.43+16.04.20160203-0ubuntu2, 
0.4.45+16.04.20160828.1-0ubuntu1)
liboxideqtcore-dev:amd64 (1.16.8-0ubuntu0.16.04.1~overlay1, 
1.17.7-0ubuntu0.16.04.1)
libthumbnailer-qt1.0:amd64 (2.4+16.04.20160719-0ubuntu1, 
2.4+16.04.20160825-0ubuntu1)
qml-module-ubuntu-thumbnailer0.1:amd64 (2.4+16.04.20160719-0ubuntu1, 
2.4+16.04.20160825-0ubuntu1)
gir1.2-webkit2-4.0:amd64 (2.10.9-1ubuntu1, 2.12.5-0ubuntu0.16.04.1)
qml-module-ubuntu-components:amd64 
(1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 1.3.2085+16.04.20160831.4)
ubuntu-download-manager:amd64 (1.3+16.04.20160812.2-0ubuntu1, 
1.3+16.04.20160909.1-0ubuntu1)
packagekit-plugin-click:amd64 (0.4.43+16.04.20160203-0ubuntu2, 
0.4.45+16.04.20160828.1-0ubuntu1)
libubuntutoolkit5:amd64 (1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 
1.3.2085+16.04.20160831.4)
phablet-tools-bileto:amd64 (1.2.1+16.04.20160906-0ubuntu1, 
1.2.1+16.04.20160913-0ubuntu1)
libubuntugestures5:amd64 (1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 
1.3.2085+16.04.20160831.4)
ubuntu-ui-toolkit-theme:amd64 (1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 
1.3.2085+16.04.20160831.4)
libjavascriptcoregtk-4.0-18:amd64 (2.10.9-1ubuntu1, 2.12.5-0ubuntu0.16.04.1)
phablet-tools-citrain:amd64 (1.2.1+16.04.20160906-0ubuntu1, 
1.2.1+16.04.20160913-0ubuntu1)
libwebkit2gtk-4.0-37-gtk2:amd64 (2.10.9-1ubuntu1, 2.12.5-0ubuntu0.16.04.1)
gir1.2-javascriptcoregtk-4.0:amd64 (2.10.9-1ubuntu1, 2.12.5-0ubuntu0.16.04.1)
libmediascanner-2.0-4:amd64 (0.111+16.04.20160526-0ubuntu1, 
0.112+16.04.20160909-0ubuntu1)
ubuntu-ui-toolkit-examples:amd64 
(1.3.2073+16.04.20160824build1~~xenialoverlay1~1, 1.3.2085+16.04.20160831.4)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to webbrowser-app in Ubuntu.
https://bugs.launchpad.net/bugs/1623841

Title:
  9 unit test failures in tst_QmlTests

Status in webbrowser-app package in Ubuntu:
  In Progress

Bug description:
  I upgraded packages on my laptop today (xenial + stable overlay PPA)
  and builds of lp:webbrowser-app started failing in tst_QmlTests.

  Those are the failures I’m seeing:

  FAIL!  : QmlTests::NewTabView::test_delete_top_site() Uncaught exception: 
Cannot read property 'x' of undefined
     Loc: 
[/build/webbrowser-app/trunk/tests/unittests/qml/WebbrowserTestCase.qml(26)]
  FAIL!  : QmlTests::NewTabView::test_expand_bookmarks() 'verify()' returned 
FALSE. ()
     Loc: 
[/build/webbrowser-app/trunk/tests/unittests/qml/tst_NewTabView.qml(82)]
  FAIL!  : QmlTests::NewTabView::test_keyboard_navigation() 'verify()' returned 
FALSE. ()
     Loc: 
[/build/webbrowser-app/trunk/tests/unittests/qml/tst_NewTabView.qml(82)]
  FAIL!  : QmlTests::NewTabView::test_keyboard_navigation() 'verify()' returned 
FALSE. ()
     Loc: 
[/build/webbrowser-app/trunk/tests/unittests/qml/tst_NewTabView.qml(189)]
  FAIL!  : QmlTests::TabsBar::test_context_menu_close() Uncaught exception: 
Cannot read property 'x' of undefined
     Loc: 
[/build/webbrowser-app/trunk/tests/unittests/qml/WebbrowserTestCase.qml(26)]
  FAIL!  : QmlTests::TabsBar::test_context_menu_new_tab() Uncaught exception: 
Cannot read property 'x' of undefined
     Loc: 
[/build/webbrowser-app/trunk/tests/unittests/qml/WebbrowserTestCase.qml(26)]
  FAIL!  : QmlTests::TabsBar::test_context_menu_reload() Uncaught exception: 
Cannot read property 'x' of undefined
     Loc: 
[/build/webbrowser-app/trunk/tests/unittests/qml/WebbrowserTestCase.qml(26)]
  FAIL!  : QmlTests::TabsBar::test_menu_states_on_new_tab() Uncaught exception: 
Cannot read property 'enabled' of null
     Loc: [/build/webbrowser-app/trunk/tests/unittests/qml/tst_TabsBar.qml(245)]
  FAIL!  : QmlTests::TabsBar::test_menu_states_on_page() Uncaught exception: 
Cannot read property 'enabled' of null
     Loc: [/build/webbrowser-app/trunk/tests/unittests/qml/tst_TabsBar.qml(256)]

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/webbrowser-app/+bug/1623841/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to