Hi,
yeah, this is a really an old issue. Nevertheless there are other problems 
involved here - one thing is the app being unable to work after some change in 
the connection but the other is the whole OS freezing and reinitializing itself 
after about 10 to 60 seconds (not rebooting but starting directly from the 
Ubuntu dotted loading screen).

I experience behaviour quite often to be honest, like 1 of 10 times I am
using my phone in a subway when my connection fluctuates from none any
(I've also seen this when my phone switched from cellular to wireless
and the vice versa). I am not sure what happens when my phone is in my
pocket untouched though. Sadly those spontaneous "almost-restarts" kill
all my applications and any stuff I may be working on there.

This happens for me on MX4 and I am not exactly sure when I saw it the
first time but it wasn't that long ago ... maybe something like
April/May 2016? (just a guess)

The system freeze bug I am experiencing may not be related to this
though, I am not sure. When Telegram ceases working for me I am usually
still able to kill it and start again, sometimes even send a message,
before the whole system stops responding. Then it takes up to two
minutes for it to realize it is stuck before it reinitializes itself.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qtbase-opensource-src in
Ubuntu.
https://bugs.launchpad.net/bugs/1555751

Title:
  Some apps require a restart after switching to/from Wifi/Cellular to
  reconnect to the network

Status in Canonical System Image:
  Confirmed
Status in qtbase-opensource-src package in Ubuntu:
  Confirmed

Bug description:
  Some apps require a restart after switching to/from Wifi/Cellular to
  reconnect to the network

  What happened:
  1) Ensure wifi is connected
  2) Start Dekko
  3) Refresh the inbox (notice the bouncing/loading bar stops eventually)
  4) Disable wifi so you are on cellular
  5) Refresh the inbox (notice the bouncing/loading bar stays continuously)

  Note
  - if after step 5 you restart the app it is fine
  - this only occurs on certain apps, specifically Dekko and Telegram are the 
ones that i've noticed so far. (Both of which i assume try to have a long 
running open network connection?)

  What I expected to happen:
  At step 5) for the connection to automatically change to using Cellular and 
not require an app restart

  $ system-image-cli -i
  current build number: 258
  device name: mako
  channel: ubuntu-touch/rc-proposed/bq-aquaris.en
  last update: 2016-03-10 15:48:08
  version version: 258
  version ubuntu: 20160310
  version device: 20160304.2
  version custom: 20160201-5-vivid

To manage notifications about this bug go to:
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1555751/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to