** Changed in: linux (Ubuntu Vivid)
       Status: In Progress => Fix Committed

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to e2fsprogs in Ubuntu.
https://bugs.launchpad.net/bugs/1619918

Title:
  lsattr 32bit does not work on 64bit kernel (Inappropriate ioctl error)

Status in e2fsprogs package in Ubuntu:
  Invalid
Status in linux package in Ubuntu:
  Fix Released
Status in e2fsprogs source package in Trusty:
  Invalid
Status in linux source package in Trusty:
  Fix Committed
Status in e2fsprogs source package in Vivid:
  Invalid
Status in linux source package in Vivid:
  Fix Committed
Status in e2fsprogs source package in Xenial:
  Invalid
Status in linux source package in Xenial:
  Fix Committed
Status in e2fsprogs source package in Yakkety:
  Invalid
Status in linux source package in Yakkety:
  Fix Released

Bug description:
  I run an amd64 kernel on trusty.  The e2fsprogs package was still the
  32 bit i386 variety.  This lead to the following situation (for
  essentially all files on a btrfs partition).

  $ lsattr 
/lib/modules/3.13.0-95-generic/kernel/drivers/staging/lustre/lustre/ptlrpc/ptlrpc.ko
  lsattr: Inappropriate ioctl for device While reading flags on 
/lib/modules/3.13.0-95-generic/kernel/drivers/staging/lustre/lustre/ptlrpc/ptlrpc.ko

  The problem was resolved by installing e2fsprogs:amd64.

  https://patchwork.kernel.org/patch/7517361/ might be related.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/e2fsprogs/+bug/1619918/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to