It's the hardware. Response from Asus:

"After consulting with our team we were advised that this would not be
possible due to the integrated graphics on the notebook."

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.

  Cannot Change Refresh Rate to 144Hz in Ubuntu 16.04 - “Configure crtc
  0 failed” (Intel Graphics)

Status in xorg package in Ubuntu:

Bug description:

  I have a new **Asus F556U** laptop and an **Asus VG248QE** monitor
  that I cannot get into 144Hz mode. It is stuck in 60Hz. This is
  causing awful eye strain and I am willing to pay/bounty whomever gets
  me a fix.

  1.Initial `xrandr`:

      $ xrandr -q
      Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
      eDP1 connected (normal left inverted right x axis y axis)
         1920x1080     60.05 +  59.93  
         1680x1050     59.95    59.88  
         1600x1024     60.17  
         1400x1050     59.98  
         1600x900      60.00  
         1280x1024     60.02  
         1440x900      59.89  
         1280x960      60.00  
         1368x768      60.00  
         1360x768      59.80    59.96  
         1152x864      60.00  
         1280x720      60.00  
         1024x768      60.00  
         1024x576      60.00  
         960x540       60.00  
         800x600       60.32    56.25  
         864x486       60.00  
         640x480       59.94  
         720x405       60.00  
         640x360       60.00  
      DP1 disconnected (normal left inverted right x axis y axis)
      HDMI1 disconnected (normal left inverted right x axis y axis)
      HDMI2 connected primary 1920x1080+0+0 (normal left inverted right x axis 
y axis) 531mm x 299mm
         1920x1080     60.00*+  50.00    59.94    59.99  
         1920x1080i    60.00    50.00    59.94  
         1680x1050     59.88  
         1280x1024     75.02    60.02  
         1440x900      59.90  
         1280x960      60.00  
         1366x768      59.79  
         1280x800      59.91  
         1152x864      75.00  
         1280x720      60.00    50.00    59.94  
         1024x768      75.08    70.07    60.00  
         832x624       74.55  
         800x600       72.19    75.00    60.32    56.25  
         720x576       50.00  
         720x480       60.00    59.94  
         640x480       75.00    66.67    60.00    59.94  
         720x400       70.08  
      VIRTUAL1 disconnected (normal left inverted right x axis y axis)

  So *HDMI2* is my monitor.

  2.Get the modeline:

      $ cvt 1920 1080 144
      # 1920x1080 143.88 Hz (CVT) hsync: 169.35 kHz; pclk: 452.50 MHz
      Modeline "1920x1080_144.00"  452.50  1920 2088 2296 2672  1080 1083 1088 
1177 -hsync +vsync

  3.Create the new mode:

      $ xrandr --newmode "1920x1080_144.00"  452.50  1920 2088 2296 2672
  1080 1083 1088 1177 -hsync +vsync

  4.*Add* the new mode:

      $ xrandr --verbose --addmode HDMI2 "1920x1080_144.00"

  All is well up to this point... and then:

  5.Output the new mode:

      $ xrandr --output HDMI2 --mode "1920x1080_144.00"
      xrandr: Configure crtc 0 failed

  The screen shuts off and back on after I hit enter, and then the **xrandr: 
Configure crtc 0 failed** error comes up.

  At that time, this is what gets dumped to `Xorg.0.log`:

      ==> Xorg.0.log <==
      [700593.713] (II) intel(0): switch to mode 1920x1080@143.9 on HDMI2 using 
pipe 0, position (0, 0), rotation normal, reflection none
      [700593.720] (EE) intel(0): failed to set mode: Invalid argument [22]
      [700593.755] (II) intel(0): switch to mode 1920x1080@60.0 on HDMI2 using 
pipe 0, position (0, 0), rotation normal, reflection none

  I have also tried `xrandr --output HDMI2 --mode "1920x1080_144.00" --crtc 1` 
and `xrandr --output HDMI2 --mode "1920x1080_144.00" --crtc 2` and those CRTCs 
fail as well.

  From `lspci`, I have an Intel Integrated Graphics Controller

      00:02.0 VGA compatible controller: Intel Corporation Sky Lake
  Integrated Graphics (rev 07)

  Not sure if it matters, but I'm running Ubuntu Classic (Metacity window 
manager). I already have the `xserver-xorg-video-intel` package installed.

  I have *not* messed with any `Xorg.conf` files on this machine. Maybe that is 

  This monitor *has* worked with an older NVidia graphics controller, so if I 
have to get a USB one, I'd be willing to do that if nothing else works.

  Any help would be greatly appreciated!


  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.4.0-34.53-generic 4.4.15
  Uname: Linux 4.4.0-34-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
  CompizPlugins: No value set for 
  CompositorRunning: None
  CurrentDesktop: GNOME-Flashback:Unity
  Date: Wed Sep  7 11:03:01 2016
  DistUpgraded: Fresh install
  DistroCodename: xenial
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes
   Intel Corporation Sky Lake Integrated Graphics [8086:1916] (rev 07) (prog-if 
00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Skylake Integrated Graphics [1043:1c7d]
  InstallationDate: Installed on 2016-08-19 (19 days ago)
  InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-34-generic.efi.signed 
root=UUID=3580df25-20a0-4f1d-a3cd-1b53556c50bb ro quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install) 03/09/2016
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: X556UA.402
  dmi.board.asset.tag: ATN12345678901234567 X556UA
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: ATN12345678901234567
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
dmi:bvnAmericanMegatrendsInc.:bvrX556UA.402:bd03/09/2016:svnASUSTeKCOMPUTERINC.:pnX556UA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnX556UA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0: X556UA
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.67-1ubuntu0.16.04.2
  version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2.1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2.1
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2.3
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
  xserver.bootTime: Tue Aug 30 08:52:10 2016
  xserver.configfile: default
  xserver.errors: intel(0): failed to set mode: Invalid argument [22]
  xserver.logfile: /var/log/Xorg.0.log
   product id                                9381 
   vendor                                     ACI
  xserver.version: 2:1.18.3-1ubuntu2.3

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to