We don't want to pull this in as a completely separate source package;
that doesn't address the support problem, as it's precisely the "forked"
version that we would need to support.

Since there is no library transition here, and it sounds like the risk
of an ABI break before 4.2 releases is quite low, and you have committed
to dealing with any collateral damage, FFe granted.

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to zeromq3 in Ubuntu.
https://bugs.launchpad.net/bugs/1612240

Title:
  [FFe] Please upgrade zeromq3 and zmqpp to 4.1.2 git snapshot

Status in zeromq3 package in Ubuntu:
  Confirmed
Status in zmqpp package in Ubuntu:
  In Progress

Bug description:
  Please update zmqpp to version 4.1.2 with the following patch that I proposed 
upstream (it got merged into their "develop" branch):
  https://github.com/zeromq/zmqpp/pull/167/files

  (alternatively, use master + my patch or develop branch of zmqpp).

  This will require the current git snapshot of the zmq library (which
  will be version 4.2 when it's released) -
  https://github.com/zeromq/libzmq

  All the above is needed to support the new USE_FD socket option, which
  will probably be critical for scopes as snaps.

  == Feature Freeze Exception details ==

  These packages are required by the ongoing work of the unity scopes
  for snappy. Due to unrelated to zeromq issues (unity-scopes-api unit-
  test issues on arm64, possibly due to recent toolchain changes) we did
  not make it in time before Feature Freeze. The packages have been
  prepared and tested in:

  https://launchpad.net/~ci-train-ppa-
  
service/+archive/ubuntu/landing-005/+packages?field.name_filter=&field.status_filter=published&field.series_filter=yakkety

  There is no ABI breakage in zeromq3 so no reverse-depends rebuilds are
  required. The zmqpp package does break ABI so a so bump and rebuild of
  rev-deps was needed, but the currently only consumer of the zmqpp
  packages is unity-scopes-api. The new release of zeromq3 is based on a
  git snapshot as a new stable release of this project is planned in the
  nearest future, so a bit too late for the current plans. Some reverse-
  depends of zeromq3 have been tested to work fine with the new package
  as is.

  We kindly request a FFe for this very particular case.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/zeromq3/+bug/1612240/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to