I just lost 3 days to this issue before I realized what was happening. I
realize this is an edge case, and understand the issues with fixing
this, but at least some type of better error messages would have helped
prevent that waste of time.

I was trying to setup a host to run docker with macvlan networks mapped
to vlan interfaces on a pair of USB ethernet adapters connected to a
BRIX used for testing. Couldn't get a bond on the pair to work, couldn't
figure out why, then tried for just VLAN interfaces, and that didn't
work either. Thought I was losing it, didn't seem that hard.

Not sure how I figured it out, but realized if I switched back to using
eth1, eth2 for the USB ethernet devices, using "net.ifnames=0
biosdevname=0" boot options + old-style mac-address rules to map, I
could get everything to work. But, wasn't happy with the workaround, as
I'd prefer to use the new predictable names.

I like the idea of using last 6 digits of Mac address. I thought of doing this:
sudo ln -s /dev/null /etc/udev/rules.d/73-usb-net-by-mac.rules
to go back to slot names, but if I plug into different ports, names change, so 

Perhaps some different prefix other than enx to avoid confusion,
usb123456 anyone?

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.

  USB NICs get too long name for ifupdown aliases or bridge names

Status in systemd package in Ubuntu:

Bug description:
  I have a USB NIC that is connected to my denial system. I tried to
  create an alias, and after reboot, it wasn't created. When I manually
  try to bring it up I have the error.


  auto enx000ec688b79f
  iface enx000ec688b79f inet static

  auto enx000ec688b79f:1
  iface enx000ec688b79f:1 inet static

  ubuntu@maas00:~$ sudo ifup enx000ec688b79f
  ubuntu@maas00:~$ sudo ifup enx000ec688b79f:1
  RTNETLINK answers: Numerical result out of range
  Failed to bring up enx000ec688b79f:1.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to