The latest PPA (0.122ubuntu8.3+lp1631474b2) passes verification for me.

$ cat /proc/cmdline 
root=LABEL=cloudimg-rootfs ro console=hvc0 ip=dhcp tsc=reliable 

$ dpkg -l|grep initramfs-tools
ii  initramfs-tools                  0.122ubuntu8.3+lp1631474b2      all        
  generic modular initramfs generator (automation)
ii  initramfs-tools-bin              0.122ubuntu8.3+lp1631474b2      amd64      
  binaries used by initramfs-tools
ii  initramfs-tools-core             0.122ubuntu8.3+lp1631474b2      all        
  generic modular initramfs generator (core tools)

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.

  No networking with initramfs-tools 0.122ubuntu8.3 and ip=dhcp boot

Status in initramfs-tools package in Ubuntu:
  In Progress
Status in initramfs-tools source package in Xenial:
Status in initramfs-tools source package in Yakkety:
  In Progress

Bug description:

   * 0.122ubuntu8.3 of initramfs-tools no longer correctly processed
  ip=dhcp or ip=:::::eth0:dhcp

   * Regression-updates

   * The fix better parses the ip= command line argument.

  [Test Case]

   * Create a machine that boots using an nfsroot.

   * Use ip=:::::eth0:dhcp on the kernel command line.  To set up

   * Discover that the device never comes up because, networking is not
  configured correctly.

  [Regression Potential]

   * Regressions potential is limited to machines using
  ip={""|::::*|on|any|dhcp} on the kernel command line.  As this is
  already broken regression potential is minimal.  This is common on
  machines that use nfsroot or otherwise pxe boot.

  [Other Info]

   * There are a number of other issues in this code base that are not solved 
by this fix.
   * The networking configuration does not strictly follow the kernel 
documentation as described . This 
should be fixed.

  ====================Original Bug Description Follows==================

  initramfs-tools 0.122ubuntu8.3 introduced a serious regression where
  networking is not initialized when the boot option "ip=dhcp" is
  provided. We are seeing this problem in AWS, but cannot confirm if
  this issue is specific to AWS or will occur with different hardware or
  in different environments.

  Removing "ip=dhcp" from the boot options with 0.122ubuntu8.3 results
  in networking being configured.

  The issue does not occur with 0.122ubuntu8.2 or previous versions when
  "ip=dhcp" is set.

  AWS has no console so debugging is not a trivial task. I do have a
  console log with some output, and will update this bug shortly with

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to