Public bug reported:

with xenial-updates, there is suddenly a dependency [isc-dhcp-client]
not previously there.  please mark this as recommends/suggests/enhances
instead of as a depends, as it is not critical to the core functionality
of the software.  since ubuntu now defaults to installing recommends
unless configured otherwise, this compromise accommodates both the
unskilled users as well as those who know what they are doing and have
disabled automatic installation of suggested packages.

1] >lsb_release -rd
Description:    Ubuntu 16.04.1 LTS
Release:        16.04

2] >apt-cache policy initramfs-tools
initramfs-tools:
  Installed: 0.122ubuntu8.3
  Candidate: 0.122ubuntu8.3
  Version table:
 *** 0.122ubuntu8.3 500
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 
Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 
Packages
        100 /var/lib/dpkg/status
     0.122ubuntu8 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial/main i386 Packages

3] i expected to not be forced to install unnecessary packages
4] i was forced to

thanks

** Affects: initramfs-tools (Ubuntu)
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to initramfs-tools in Ubuntu.
https://bugs.launchpad.net/bugs/1633643

Title:
  unnecessary dependency upon isc-dhcp-client

Status in initramfs-tools package in Ubuntu:
  New

Bug description:
  with xenial-updates, there is suddenly a dependency [isc-dhcp-client]
  not previously there.  please mark this as
  recommends/suggests/enhances instead of as a depends, as it is not
  critical to the core functionality of the software.  since ubuntu now
  defaults to installing recommends unless configured otherwise, this
  compromise accommodates both the unskilled users as well as those who
  know what they are doing and have disabled automatic installation of
  suggested packages.

  1] >lsb_release -rd
  Description:  Ubuntu 16.04.1 LTS
  Release:      16.04

  2] >apt-cache policy initramfs-tools
  initramfs-tools:
    Installed: 0.122ubuntu8.3
    Candidate: 0.122ubuntu8.3
    Version table:
   *** 0.122ubuntu8.3 500
          500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 
Packages
          500 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 
Packages
          100 /var/lib/dpkg/status
       0.122ubuntu8 500
          500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
          500 http://us.archive.ubuntu.com/ubuntu xenial/main i386 Packages

  3] i expected to not be forced to install unnecessary packages
  4] i was forced to

  thanks

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1633643/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to