Any progress on this bug?

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to upower in Ubuntu.

  Upgrading upower package caused forced reboot

Status in Upower:
Status in upower package in Ubuntu:

Bug description:
  When upower was updated, the system claimed that my UPS was empty.
  The system then proceeded to shut down.  On reboot, the UPS was fully
  charged as expected.

  This is a major data loss concern.  The system shut down while
  upgrading packages.  Perhaps the bug is in the handling of my specific
  UPS but it's still important.

  jlquinn@cerberus:~$ lsb_release -rd
  Description:  Ubuntu 16.04 LTS
  Release:      16.04

  jlquinn@cerberus:~$ apt-cache policy upower
    Installed: 0.99.4-2ubuntu0.2
    Candidate: 0.99.4-2ubuntu0.2
    Version table:
   *** 0.99.4-2ubuntu0.2 500
          500 xenial-updates/main amd64 
          100 /var/lib/dpkg/status
       0.99.4-2 500
          500 xenial/main amd64 Packages

  output of lsusb -v for my UPS

  Bus 003 Device 002: ID 0764:0501 Cyber Power System, Inc. CP1500 AVR UPS
  Device Descriptor:
    bLength                18
    bDescriptorType         1
    bcdUSB               1.10
    bDeviceClass            0 (Defined at Interface level)
    bDeviceSubClass         0 
    bDeviceProtocol         0 
    bMaxPacketSize0         8
    idVendor           0x0764 Cyber Power System, Inc.
    idProduct          0x0501 CP1500 AVR UPS
    bcdDevice            0.01
    iManufacturer           3 CPS
    iProduct                1 CP625HGa
    iSerial                 0 
    bNumConfigurations      1
    Configuration Descriptor:
      bLength                 9
      bDescriptorType         2
      wTotalLength           34
      bNumInterfaces          1
      bConfigurationValue     1
      iConfiguration          0 
      bmAttributes         0x80
        (Bus Powered)
      MaxPower               50mA
      Interface Descriptor:
        bLength                 9
        bDescriptorType         4
        bInterfaceNumber        0
        bAlternateSetting       0
        bNumEndpoints           1
        bInterfaceClass         3 Human Interface Device
        bInterfaceSubClass      0 No Subclass
        bInterfaceProtocol      0 None
        iInterface              0 
          HID Device Descriptor:
            bLength                 9
            bDescriptorType        33
            bcdHID               1.10
            bCountryCode           33 US
            bNumDescriptors         1
            bDescriptorType        34 Report
            wDescriptorLength     410
           Report Descriptors: 
             ** UNAVAILABLE **
        Endpoint Descriptor:
          bLength                 7
          bDescriptorType         5
          bEndpointAddress     0x81  EP 1 IN
          bmAttributes            3
            Transfer Type            Interrupt
            Synch Type               None
            Usage Type               Data
          wMaxPacketSize     0x0008  1x 8 bytes
          bInterval              10
  Device Status:     0x0000
    (Bus Powered)

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: upower 0.99.4-2ubuntu0.2
  ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
  Uname: Linux 4.4.0-22-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Wed Jun  8 00:27:23 2016
  InstallationDate: Installed on 2016-05-30 (8 days ago)
  InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
  SourcePackage: upower
  UpgradeStatus: Upgraded to xenial on 2016-05-31 (7 days ago)

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to