Sorry, what does this mean? I do not understand.
Looking forward to your reply.
Have a great day

2017-08-11 6:11 GMT+08:00 Pat Ferrel <p...@occamsmachete.com>:

> Just installed Xenial with all updates and can't install zlib1g-dev. It
> does not exist in proposed (tried from there) so I assume it's in the
> usual update repos. It looks like it is still broken. Is there a work
> around?
>
> sudo apt-get -o Dpkg::Options::="--force-overwrite" install
> zlib1g-dev:amd64
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  zlib1g-dev : Depends: zlib1g (= 1:1.2.8.dfsg-2ubuntu4) but
> 1:1.2.8.dfsg-2ubuntu4.1 is to be installed
> E: Unable to correct problems, you have held broken packages.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1673348).
> https://bugs.launchpad.net/bugs/1512992
>
> Title:
>   package zlib1g-dev 1:1.2.8.dfsg-2ubuntu4 failed to install/upgrade:
>   trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is
>   also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
>
> Status in One Hundred Papercuts:
>   Fix Released
> Status in zlib package in Ubuntu:
>   Fix Released
> Status in zlib source package in Xenial:
>   Fix Released
> Status in zlib source package in Yakkety:
>   Fix Released
>
> Bug description:
>   Test Case
>   ---------
>   1) Install zlib1g-dev:i386
>   2) Install lib32z1-dev.
>   3) Observe a package installation failure
>
>   After enabling -proposed you should be able to install both packages
>   without an issue.
>
>   Original Description
>   --------------------
>
>   The package did not install when I did a fresh install of 15.10.
>
>   ProblemType: PackageDistroRelease: Ubuntu 15.10
>   Package: zlib1g-dev 1:1.2.8.dfsg-2ubuntu4
>   ProcVersionSignature: Ubuntu 4.2.0-17.21-generic 4.2.3
>   Uname: Linux 4.2.0-17-generic x86_64
>   NonfreeKernelModules: nvidia
>   ApportVersion: 2.19.1-0ubuntu4
>   Architecture: amd64
>   Date: Wed Nov  4 10:36:43 2015
>   DuplicateSignature: package:zlib1g-dev:1:1.2.8.dfsg-2ubuntu4:trying to
> overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package
> lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
>   ErrorMessage: trying to overwrite '/usr/include/i386-linux-gnu/zconf.h',
> which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
>   InstallationDate: Installed on 2015-11-04 (0 days ago)
>   InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64
> (20151021)
>   RelatedPackageVersions:
>    dpkg 1.18.2ubuntu5
>    apt  1.0.10.2ubuntu1SourcePackage: zlib
>   Title: package zlib1g-dev 1:1.2.8.dfsg-2ubuntu4 failed to
> install/upgrade: trying to overwrite '/usr/include/i386-linux-gnu/zconf.h',
> which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
>   UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/1512992/+subscriptions
>

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to zlib in Ubuntu.
https://bugs.launchpad.net/bugs/1512992

Title:
  package zlib1g-dev 1:1.2.8.dfsg-2ubuntu4 failed to install/upgrade:
  trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is
  also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4

Status in One Hundred Papercuts:
  Fix Released
Status in zlib package in Ubuntu:
  Fix Released
Status in zlib source package in Xenial:
  Fix Released
Status in zlib source package in Yakkety:
  Fix Released

Bug description:
  Test Case
  ---------
  1) Install zlib1g-dev:i386 
  2) Install lib32z1-dev.
  3) Observe a package installation failure

  After enabling -proposed you should be able to install both packages
  without an issue.

  Original Description
  --------------------

  The package did not install when I did a fresh install of 15.10.

  ProblemType: PackageDistroRelease: Ubuntu 15.10
  Package: zlib1g-dev 1:1.2.8.dfsg-2ubuntu4
  ProcVersionSignature: Ubuntu 4.2.0-17.21-generic 4.2.3
  Uname: Linux 4.2.0-17-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.19.1-0ubuntu4
  Architecture: amd64
  Date: Wed Nov  4 10:36:43 2015
  DuplicateSignature: package:zlib1g-dev:1:1.2.8.dfsg-2ubuntu4:trying to 
overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package 
lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
  ErrorMessage: trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', 
which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
  InstallationDate: Installed on 2015-11-04 (0 days ago)
  InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
  RelatedPackageVersions:
   dpkg 1.18.2ubuntu5
   apt  1.0.10.2ubuntu1SourcePackage: zlib
  Title: package zlib1g-dev 1:1.2.8.dfsg-2ubuntu4 failed to install/upgrade: 
trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in 
package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/hundredpapercuts/+bug/1512992/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to