The solution is indeed to install the qt5-default package.

Maybe this package could be added as a dependency in newer releases?

There is also perhaps an upstream bug where qtchooser could try the
"other" qt version if one fails. (I had installed qdbus5, and qtchooser
was trying qdbus4, which was not installed or wanted.)

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to qt4-x11 in Ubuntu.

  qdbus and qdbusviewer crash with "No such file or directory"

Status in qt4-x11 package in Ubuntu:
Status in qtchooser package in Ubuntu:

Bug description:
  Release: Ubuntu 13.10 (32-bit)

  Package versions:
  qtdbus 4:4.8.4+dfsg-0ubuntu18
  qtchooser 26-3ubuntu2

  Expected behavior:

  The `qdbus` program runs, as does the related program `qdbusviewer`.

  Actual behavior:

  If I run the `qdbus` program, it always crashes:

  user@host:~$ qdbus --help
  qdbus: could not exec '/usr/lib/i386-linux-gnu/qt5/bin/qdbus': No such file 
or directory

  The `qdbus` executable is actually:

  user@host:~$ ls --full-time $(which qdbus)
  lrwxrwxrwx 1 root root 9 2013-08-07 14:48:40.000000000 +0000 /usr/bin/qdbus 
-> qtchooser

  Note that `/usr/lib/i386-linux-gnu/qt4/bin/qdbus` exists and seems to
  work if I invoke it directly.

  There's a `qdbus-qt5` package in the universe repository. It was not
  pulled in as a dependency, but manually installing it fixes the issue.
  Therefore it's either a packaging error or a bug in qtchooser.

  A similar thing happens if I run `qdbusviewer`:

  user@host:~$ qdbusviewer
  qdbusviewer: could not exec '/usr/lib/i386-linux-gnu/qt5/bin/qdbusviewer': No 
such file or directory

  except that installing `qdbus-qt5` doesn't fix the issue.

  ProblemType: Bug
  DistroRelease: Ubuntu 13.10
  Package: qdbus 4:4.8.4+dfsg-0ubuntu18
  ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
  Uname: Linux 3.11.0-13-generic i686
  ApportVersion: 2.12.5-0ubuntu2.1
  Architecture: i386
  Date: Thu Nov 14 09:34:24 2013
  MarkForUpload: True
  SourcePackage: qt4-x11
  UpgradeStatus: Upgraded to saucy on 2013-10-23 (22 days ago)

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to