Before I submitted this, I had run the following command, per the web
page mentioned above.

sudo apt-get install libnl-3-200=3.2.21-1 libnl-route-3-200=3.2.21-1

After submitting this, I ran the following commands:

sudo apt-get update
sudo apt-get install network-manager

network-manager was reinstalled, and my server gets connected to the LAN
again automatically after I reboot. network-manager-gnome was also
reinstalled. I'd like to know if I can safely do

sudo apt-mark unhold libnl-3-200 libnl-genl-3-200 libnl-route-3-200

For now, I'll just stick with the downgraded libnl packages as I don't
want to have more networking problems.

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to network-manager in Ubuntu.

  Have to manually "sudo ifconfig eth0 up" and "sudo dhclient eth0"
  after every reboot

Status in network-manager package in Ubuntu:

Bug description:
  I did an upgrade with "sudo apt-get dist-upgrade", and it removed 
network-manager and network-manager-gnome. I could not connect to my LAN afer 
that. I was able to find instructions for downgrading the libnl packages at

  I am able to get online again by running the following commands
  sudo ifconfig eth0 up
  sudo dhclient eth0
  (Fortunately, I have a Ethernet I can plug in to.) I have to do this every 
time I reboot. This is inconvenient as a usually use Desktop Sharing with 
another computer as the client. I use an SSH tunnel for security. This means 
that every time I reboot, I have to physically access the computer's console to 
enter the ifconfig and dhclient commands to get the computer back on the 
network. I tried to reinstall network-manager and network-manager-gnome, but 
the command results said there were dependencies that prevented the 
installation. The fixes in the web page referenced above do not help, so I'm 
reporting this as a bug.

  Thanks for your assistance.

  $ sudo lsb_release -rd
  [sudo] password for wally: 
  Description:  Ubuntu 14.04.1 LTS
  Release:      14.04

  $ apt-cache policy network-manager
    Installed: (none)
    Version table: 0
          500 trusty-security/main amd64 
          100 /var/lib/dpkg/status 0
          500 trusty/main amd64 Packages

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: network-manager (not installed)
  ProcVersionSignature: Ubuntu 3.13.0-144.193-generic 3.13.11-ckt39
  Uname: Linux 3.13.0-144-generic x86_64
  ApportVersion: 2.14.1-0ubuntu3.27
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Fri Apr  6 21:21:27 2018
  InstallationDate: Installed on 2014-10-22 (1262 days ago)
  InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 
   PATH=(custom, no user)
  SourcePackage: network-manager
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to