just ran into this myself a few days ago when updating to bionic.  It
was pure luck that I discovered the problem and fix.

** Tags added: bionic

** Changed in: lightdm (Ubuntu)
   Importance: Undecided => High

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to lightdm in Ubuntu.

  Lightdm doesn't give any error message when .XAutority is owned by

Status in lightdm package in Ubuntu:

Bug description:
  (Orignal problem at the end)

  I understood the problem : As I had to sudo startx previously,
  .XAutority was owned by root. So Lightdm wasn't able to log me in. But
  Lightdm doesn't display any error message explaining why it can't log
  me in, as there was previously in GDM.

  HOW to reproduce : made root the owner of the .XAutority file at the
  root of your personal home, then try to login via Lightdm. It doesn't
  display any message but it doesn't log you.

  ---------------------Original problem :------------------------

  So here is what happened : To test if an old bug with menus is still
  present in Trusty I updated to it, but it went very wrong (no screen
  at all, I filed this bug by going to recovery mode and FailsafeX). So
  I tried installing Trusty "from scratch", but I kept my /home. I used
  the same ID and Password during the installation as I do each
  reinstall. Reinstall corrected the problem of no screen : I was on
  lightdm login screen. Then, impossible to log me in : It tried and
  immediately go back to login screen. I changed the password from tty1
  but same problem. But I can open the guest session (from which I make
  this bug report).

  What I expected : To be able to login from lightdm as I do each time I
  have to reinstall the system.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: lightdm 1.9.5-0ubuntu1
  ProcVersionSignature: Ubuntu 3.13.0-1.16-generic 3.13.0-rc7
  Uname: Linux 3.13.0-1-generic x86_64
  ApportVersion: 2.13.1-0ubuntu1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Sun Jan 12 11:50:36 2014
  InstallationDate: Installed on 2014-01-12 (0 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140111)
   PATH=(custom, no user)
  SourcePackage: lightdm
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to