I tried `lp -d duplex -o fit-to-page -o pdftops-renderer=XXX` with
hybrid, gs, pdftops, pdftocairo, and mupdf as the renderers (for the
last I had to install both mupdf and mupdf-tools).

The only one that made it through to the printer was gs.

All claimed to print, but gs was the only one that actually did.

Please note my comments at the end of
https://bugs.launchpad.net/ubuntu/+source/gtk+2.0/+bug/428817. I using a
PPD for my printer downloaded directly from HP because for some
inexplicable reason it is not installed with Ubuntu (or, at least, it
was not installed with Ubuntu 18.10, when I configured the printer).
This may be relevant.

For me, the sticking point remains, why does this one PDF file cause
problems when no others (that I've seen) do?

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to cups in Ubuntu.

  Specific PDF file fails to print to HP m551dn printer

Status in cups package in Ubuntu:

Bug description:
  One particular PDF file is failing to print. I have no idea why. When
  I say failing to print I mean that my computer thinks the file printed
  but the printer shows no sign of ever having received it. The display
  of the printer never changes to show that it is receiving or printing
  a file, and the job log of the printer doesn't show that it was
  received either. I also checked the printer event log and it doesn't
  show any events at the time I attempted to print the file.

  Unfortunately I can't attach the PDF file itself because it contains
  private information, and I can't find another PDF that exhibits this
  problem. I even tried generating a new PDF exactly the same way the
  old one was generated -- with the scan to email PDF function on my
  scanner -- and the new PDF prints just fine.

  I tried uploading the PDF directly to the printer with FTP and it
  prints just fine that way.

  I enabled CUPS debug mode before attempting to print the file.
  Attached is the resulting contents of /var/log/cups/error_log.

  I wish I knew what was going on here but honestly I have no idea.
  Perhaps you can learn something from the error_log. I hope so.

  Other files, including other PDFs, do print.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.04
  Package: cups 2.2.10-3
  ProcVersionSignature: Ubuntu 4.18.0-13.14-generic 4.18.17
  Uname: Linux 4.18.0-13-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  ApportVersion: 2.20.10-0ubuntu19
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Jan 26 17:47:49 2019
  InstallationDate: Installed on 2019-01-02 (24 days ago)
  InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 
   device for duplex: socket://m551dn.kamens.brookline.ma.us:9100
   device for HP_LaserJet_500_color_M551_1637DA_: 
   device for simplex: socket://m551dn.kamens.brookline.ma.us:9100
  MachineType: Acer Predator G6-710
  Papersize: letter
   Error: command ['fgrep', '-H', '*NickName', '/etc/cups/ppd/simplex.ppd', 
'/etc/cups/ppd/duplex.ppd'] failed with exit code 2: grep: 
/etc/cups/ppd/simplex.ppd: Permission denied
   grep: /etc/cups/ppd/HP_LaserJet_500_color_M551_1637DA_.ppd: Permission denied
   grep: /etc/cups/ppd/duplex.ppd: Permission denied
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.18.0-13-generic 
root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=1
  SourcePackage: cups
  UpgradeStatus: Upgraded to disco on 2019-01-21 (5 days ago)
  dmi.bios.date: 05/18/2016
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: R01-A4
  dmi.board.name: Predator G6-710
  dmi.board.vendor: Acer
  dmi.chassis.type: 3
  dmi.chassis.vendor: Acer
  dmi.product.family: Acer Desktop
  dmi.product.name: Predator G6-710
  dmi.sys.vendor: Acer

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to