** Package changed: xorg (Ubuntu) => xorg-server (Ubuntu)

** Also affects: linux (Ubuntu)
   Importance: Undecided
       Status: New

** Package changed: linux (Ubuntu) => linux-hwe (Ubuntu)

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1821533

Title:
  failure to detect and use Intel 620 graphics pci id 3ea0

Status in linux-hwe package in Ubuntu:
  New
Status in xorg-server package in Ubuntu:
  New

Bug description:
  Booting very new laptop hardware (ASUS Zenbook UX431FA) from 18.04 usb
  install (also 18.10, also 19.04 daily) leads to black screen. Adding
  "nomodeset" to kernel boot parameter gives 800x600 video only and
  permits installing OS to disk. Applying updates and hardware
  enablement packages does not solve problem: the system will still only
  boot with nomodeset kernel option, and X is limited to using fbdev
  module at 800x600 resolution.

  The "modesetting" driver appears to be loaded and then unloaded during
  X startup. Trying to force intel module from xserver-xorg-video-intel
  by setting up 20-intel.conf file in /usr/share/X11/xorg.conf.d/ does
  not help.

  The PCI id for the graphics device appears to be 3ea0 and the place
  where that might be relevant is the i915 module.

  This problem occurs with every other Linux release I have tried
  including Fedora 29, Elementary OS latest, Mint 19.1, Manjaro latest.
  The one open source OS that I have found where it might be fixed is
  DragonFlyBSD (see https://bugs.dragonflybsd.org/issues/3167). I have
  verified that the patch referenced in that bug report does make
  DragonFlyBSD boot past the video problem which I think is the same
  problem I experience with every Linux OS I have tried including
  Ubuntu.

  guest@guest-ZenBook-UX431FA:~$ lsb_release -rd
  Description:  Ubuntu 18.04.2 LTS
  Release:      18.04

  guest@guest-ZenBook-UX431FA:~$ dpkg -l | grep hwe | egrep "linux|fbdev"
  ii  linux-generic-hwe-18.04                    4.18.0.16.66                   
              amd64        Complete Generic Linux kernel and headers
  ii  linux-headers-generic-hwe-18.04            4.18.0.16.66                   
              amd64        Generic Linux kernel headers
  ii  linux-image-generic-hwe-18.04              4.18.0.16.66                   
              amd64        Generic Linux kernel image
  ii  linux-signed-generic-hwe-18.04             4.18.0.16.66                   
              amd64        Complete Signed Generic Linux kernel and headers 
(dummy transitional package)
  ii  xserver-xorg-video-fbdev-hwe-18.04         1:0.5.0-1ubuntu1~18.04.1       
              amd64        X.Org X server -- fbdev display driver

  Expected result: Video at 1920x1080
  Actual result: Video limited to 800x600

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu7.1
  ProcVersionSignature: Ubuntu 4.18.0-16.17~18.04.1-generic 4.18.20
  Uname: Linux 4.18.0-16-generic x86_64
  ApportVersion: 2.20.9-0ubuntu7.6
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Mar 24 10:36:51 2019
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes, including running git bisection searches
  GraphicsCard:
   Intel Corporation Device [8086:3ea0] (prog-if 00 [VGA controller])
     Subsystem: ASUSTeK Computer Inc. Device [1043:17d1]
  InstallationDate: Installed on 2019-03-24 (0 days ago)
  InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 
(20190210)
  MachineType: ASUSTeK COMPUTER INC. ZenBook UX431FA
  ProcEnviron:
   TERM=xterm-256color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.18.0-16-generic 
root=UUID=e6ae272a-49f0-491b-99b6-2a3785a7679e ro nomodeset vt.handoff=1
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/14/2018
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: UX431FA.205
  dmi.board.asset.tag: ATN12345678901234567
  dmi.board.name: UX431FA
  dmi.board.vendor: ASUSTeK COMPUTER INC.
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: No  Asset  Tag
  dmi.chassis.type: 10
  dmi.chassis.vendor: ASUSTeK COMPUTER INC.
  dmi.chassis.version: 1.0
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrUX431FA.205:bd12/14/2018:svnASUSTeKCOMPUTERINC.:pnZenBookUX431FA:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnUX431FA:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
  dmi.product.family: ZenBook
  dmi.product.name: ZenBook UX431FA
  dmi.product.version: 1.0
  dmi.sys.vendor: ASUSTeK COMPUTER INC.
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.95-1~18.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 18.2.8-0ubuntu0~18.04.2
  version.libgl1-mesa-glx: libgl1-mesa-glx 18.2.8-0ubuntu0~18.04.2
  version.xserver-xorg-core: xserver-xorg-core N/A
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
  version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux-hwe/+bug/1821533/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to