Also assigned to xorg-server, because Xorg should be intercepting
Alt+KEY. If Xorg fails to do so and somehow the key events get sent to
the VT then we get the unwanted VT's interpretation of Alt+KEY.

** Description changed:

+ WORKAROUND:
+ 
+ sudo kbd_mode -s
+ 
+ ORIGINAL DESCRIPTION:
+ 
  I'm running Ubuntu Lucid development branch.
  
  Pressing alt-f2 switches the screen to the second virtual terminal.
  Alt-f3 does the same to the third and so on. I expected alt-f2 to open
  the run dialog.
  
  I'm pretty sure that my keyboard is not malfunctioning as I can use all
  my applications normally. (Pressing O and Ctrl-O do not have the same
  effect.)
  
  I'm not sure which package I should file this bug against. I'll happily
  do an apport-collect once I know.

** Also affects: linux (Ubuntu)
   Importance: Undecided
       Status: New

** Changed in: linux (Ubuntu)
       Status: New => Confirmed

** Changed in: linux (Ubuntu)
   Importance: Undecided => High

** Summary changed:

- Alt+KEY incorrectly behaves like Ctrl+Alt+KEY
+ Alt+KEY incorrectly behaves like Ctrl+Alt+KEY, and/or unwanted VT switch from 
Alt+Left/Right

** Also affects: xorg-server (Ubuntu)
   Importance: Undecided
       Status: New

** Changed in: xorg-server (Ubuntu)
       Status: New => Confirmed

** Changed in: xorg-server (Ubuntu)
   Importance: Undecided => High

-- 
You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to console-setup in Ubuntu.
https://bugs.launchpad.net/bugs/520546

Title:
  Alt+KEY incorrectly behaves like Ctrl+Alt+KEY, and/or unwanted VT
  switch from Alt+Left/Right

Status in console-setup package in Ubuntu:
  Confirmed
Status in linux package in Ubuntu:
  Confirmed
Status in xorg-server package in Ubuntu:
  Confirmed

Bug description:
  WORKAROUND:

  sudo kbd_mode -s

  ORIGINAL DESCRIPTION:

  I'm running Ubuntu Lucid development branch.

  Pressing alt-f2 switches the screen to the second virtual terminal.
  Alt-f3 does the same to the third and so on. I expected alt-f2 to open
  the run dialog.

  I'm pretty sure that my keyboard is not malfunctioning as I can use
  all my applications normally. (Pressing O and Ctrl-O do not have the
  same effect.)

  I'm not sure which package I should file this bug against. I'll
  happily do an apport-collect once I know.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/console-setup/+bug/520546/+subscriptions

-- 
Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to