I have just updated mesa from bionic-proposed and now everything is fine
on i386 Ubuntu 18.04:

~# apt-cache policy libgl1-mesa-glx 
  Встановлено: 19.0.2-1ubuntu1.1~18.04.2
  Кандидат:    19.0.2-1ubuntu1.1~18.04.2
  Таблиця версій:
 *** 19.0.2-1ubuntu1.1~18.04.2 500
        500 http://archive.ubuntu.com/ubuntu bionic-proposed/main i386 Packages
        100 /var/lib/dpkg/status

I have also tried different kernels with bad mesa
19.0.2-1ubuntu1.1~18.04.1 from bionic-updates:

linux-generic (4.15.0-54-generic) - problem exists
linux-generic-hwe-18.04 (4.18.0-25-generic) - problem exists
linux-generic-hwe-18.04-edge (5.0.0-20-generic) - everything is fine

With mesa 19.0.2-1ubuntu1.1~18.04.1 from bionic-proposed everything is
fine on all these kernels

** Tags removed: verification-needed
** Tags added: verification-done-bionic

** Tags removed: verification-needed-bionic

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.

  Black screen after updating mesa from 18.2 to 19.0 on i386 Ubuntu

Status in mesa package in Ubuntu:
  Won't Fix
Status in mesa source package in Bionic:
  Fix Committed

Bug description:
  Black screen after updating mesa from 18.2 to 19.0 on i386 Ubuntu

  ~# lsb_release -a
  No LSB modules are available.
  Distributor ID:       Ubuntu
  Description:  Ubuntu 18.04.2 LTS
  Release:      18.04
  Codename:     bionic

  ~# uname -a
  Linux WS 4.15.0-54-generic #58-Ubuntu SMP Mon Jun 24 10:55:12 UTC 2019 i686 
i686 i686 GNU/Linux

  ~# lspci -nn -k -d ::0300
  00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3e90]
        Subsystem: ASUSTeK Computer Inc. Device [1043:8694]
        Kernel driver in use: i915
        Kernel modules: i915

  mesa: 19.0.2-1ubuntu1.1~18.04.1

  X crashes with message:
   i965: Failed to submit batchbuffer: Invalid argument

  The same issue was after updating mesa from 18.0 to 18.2:

  I have tried the same fix and it works for me:

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to