** Attachment added: "kodi core dump and crash logs"

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mesa in Ubuntu.

  Kodi crashes with “nouveau_vp3_video_buffer_create: Assertion
  `templat->interlaced' failed”

Status in mesa package in Ubuntu:

Bug description:
  Buggy as Kodi is, this seems to be a problem specifically with mesa-

  Kodi has worked just fine on my system, as recently as July 6th of
  this year, but yesterday (July 16) I tried Kodi again: I got a blank
  screen and a pause for a few moments, followed by an unceremonious
  crash-to-desktop. This happens every time I start Kodi, now.

  If I run it through the command-line, I get this:

  libva info: VA-API version 1.1.0
  libva info: va_getDriverName() returns 0
  libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/
  libva info: Found init function __vaDriverInit_1_1
  libva info: va_openDriver() returns 0
  kodi-x11: ../src/gallium/drivers/nouveau/nouveau_vp3_video.c:91: 
nouveau_vp3_video_buffer_create: Assertion `templat->interlaced' failed.
  Aborted (core dumped)

  I’ve been using the same version of Kodi (“18.3 Git:20190621-89472b7”,
  package version 2:18.3+git20190621.1610-final-0bionic, from the Team-
  XBMC PPA) since its release in June, but in between July 6th and 16th,
  I did upgrade the Mesa packages, from 18.2.8-0ubuntu0~18.04.2
  19.0.2-1ubuntu1.1~18.04.1. If I downgrade the “mesa-va-drivers”
  package to 18.0.0~rc5-1ubuntu1 (the version in the base, non-updates
  Bionic repository), however, Kodi works again, without even requiring
  me to restart my machine. So, this is likely a problem with “mesa-va-

  I tried looking in Xorg.0.log:

  [ 17185.557] (II) NOUVEAU(0): EDID vendor "SEC", prod id 12620
  [ 17185.557] (II) NOUVEAU(0): Printing DDC gathered Modelines:
  [ 17185.558] (II) NOUVEAU(0): Modeline "1366x768"x0.0   72.33  1366 1414 1446 
1526  768 770 775 790 -hsync -vsync (47.4 kHz eP)

  …that’s all that appears in the log when I try to load Kodi and a
  crash happens.

  I’m using Ubuntu MATE 18.04.2 LTS 64-bit on a Compaq Presario CQ60; if
  you need more information, I’ve attached a hardinfo report, too. I
  hope this bug can get fixed, soon. Thanks!

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to