Hi Petrida,

could you please elaborate on why you changed the bug status from
incomplete to confirmed without providing the requested information from
comment #95?

** Changed in: openssh (Ubuntu)
       Status: Confirmed => Incomplete

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to openssh in Ubuntu.

  ssh Agent admitted failure to sign using the key on big endian

Status in seahorse:
  Fix Released
Status in gnome-keyring package in Ubuntu:
  Fix Released
Status in openssh package in Ubuntu:

Bug description:
  on hardy (preserved home folder from feisty) i get the following when
  i try to ssh

  Agent admitted failure to sign using the key.
  Permission denied (publickey).

  or with verbose on

  sam@titania:~$ ssh -v oberon
  OpenSSH_4.7p1 Debian-4ubuntu1, OpenSSL 0.9.8g 19 Oct 2007
  debug1: Reading configuration data /home/sam/.ssh/config
  debug1: Applying options for oberon
  debug1: Reading configuration data /etc/ssh/ssh_config
  debug1: Applying options for *
  debug1: Connecting to ###### [######] port ##.
  debug1: Connection established.
  debug1: identity file /home/sam/.ssh/identity type -1
  debug1: identity file /home/sam/.ssh/id_rsa type 1
  debug1: identity file /home/sam/.ssh/id_dsa type -1
  debug1: Remote protocol version 2.0, remote software version OpenSSH_4.6p1 
  debug1: match: OpenSSH_4.6p1 Debian-5ubuntu0.1 pat OpenSSH*
  debug1: Enabling compatibility mode for protocol 2.0
  debug1: Local version string SSH-2.0-OpenSSH_4.7p1 Debian-4ubuntu1
  debug1: SSH2_MSG_KEXINIT sent
  debug1: SSH2_MSG_KEXINIT received
  debug1: kex: server->client aes128-cbc hmac-md5 none
  debug1: kex: client->server aes128-cbc hmac-md5 none
  debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
  debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
  debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
  debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
  debug1: using hostkeyalias: oberon
  debug1: Host 'oberon' is known and matches the RSA host key.
  debug1: Found key in /home/sam/.ssh/known_hosts:1
  debug1: ssh_rsa_verify: signature correct
  debug1: SSH2_MSG_NEWKEYS sent
  debug1: expecting SSH2_MSG_NEWKEYS
  debug1: SSH2_MSG_NEWKEYS received
  debug1: SSH2_MSG_SERVICE_ACCEPT received
  debug1: Authentications that can continue: publickey
  debug1: Next authentication method: publickey
  debug1: Offering public key: /home/sam/.ssh/id_rsa
  debug1: Server accepts key: pkalg ssh-rsa blen 277
  Agent admitted failure to sign using the key.
  debug1: Trying private key: /home/sam/.ssh/identity
  debug1: Trying private key: /home/sam/.ssh/id_dsa
  debug1: No more authentication methods to try.
  Permission denied (publickey).

  I tried generating a new key. this worked for a few logons, but then i
  get back to this error.

  I think it is to do with the local key agent. i found that
   SSH_AUTH_SOCK=0 ssh oberon
  works fine.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to