The fix that worked for me is to add the libnss-resolve package.  This changes 
the /etc/nsswitch.conf file to actually attempt the dns lookup after the other 
conditions have started the UDB fallback mode.
Bug 1727237 had a comment requesting if libnss-resolve were installed, answered 
"no", but no further suggestions regarding the package.  The package changes 
the hosts line in the nsswitch.conf to:
hosts:          files mdns4_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] 
dns myhostname

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to systemd in Ubuntu.

  DNS cannot be resolved in Public / Hotel / Starbucks WiFi Hotspot

Status in systemd package in Ubuntu:
  Fix Released
Status in systemd source package in Artful:
  Won't Fix
Status in systemd source package in Bionic:
  Fix Released
Status in systemd source package in Cosmic:
  Fix Released

Bug description:

   * More captive portals have been discovered that do not handle DNS requests 
with D0 set.
   * Thus extend previous aruba-networks fix from by retrying all 
NXDOMAIN results with lower feature levels just in case.

  [Test Case]

   * systemd-resolved
   * monitor the logs, and check that the transaction has been downgraded 
multiple times and tried at least once at a feature level below D0. There 
should be a downgrade message in the log.
   * Note, it will be cached, thus one may need to call $ systemd-resolved 

  [Regression Potential]

   * Legitimate NXDOMAIN queries will now take longer, as they will be
  retried multiple times with different features sets until an answer is
  found. At that point the query will be cached and will return quickly.
  This is needed to work-around bad captive portals that do not support
  dns queries with D0. Post-captive portal, the feature level can
  usually be cranked back up and it does after a grace period.

  [Other Info]
   * Original bug report

  I was asked to create a new bug for this in as it
  seems to be a different issue.

  I have installed the nightly image of Kubuntu Bionic from 25th of

  There systemd is in version 237-3ubuntu10.

  When connecting to the wifi hotspot in my hotel (Quality Hotel
  Augsburg) I cannot open the hotspot landing page that should give me
  access to the WIFI. With Windows and on an Iphone it's working.

  For the following distributions I can confirm it not working:
  Kubuntu 17.10
  Kubuntu 18.04 (nightly image 25th of April 2018)

  The logs were taken on 18.04.

  sudo systemctl disable systemd-resolved.service
  sudo service systemd-resolved stop
  sudo rm /etc/resolv.conf
  sudo nano /etc/NetworkManager/NetworkManager.conf
    >> add "dns=default" under [main]
  sudo service network-manager restart

  Then I can connect to the WIFI and I see the login page in Firefox.

  To capture some data I did the following:
   - connect to Hotspot
   - enter

  Case 1: Fresh default Kubuntu install
  With a default Kubuntu install it does not work. I can connect to the WIFI 
and get IP and DNS from DHCP but I cannot resolve any hostname. When trying  to 
open the router ip directly in the browser it forwards to which 
cannot be resolved.

  Case 2: With aforementioned Workaround
  I connect to the wifi, I open firefox and the login page shows up (if I 
havent been connected yet. In the capture I already was able to connect to the 
hotspot which allows immediately to connect to the webpage)

  PS: I'll be in this hotel till Friday 27th if more information are

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to