(In reply to Takashi Iwai from comment #273)
> Hmm, would it be only about playback?  That is, restricting the workaround
> only to capture stream works better?
> --- a/sound/pci/hda/hda_controller.c
> +++ b/sound/pci/hda/hda_controller.c
> @@ -617,7 +617,8 @@ static int azx_pcm_open(struct snd_pcm_substream
> *substream)
>          * tsched=1 when a capture stream triggers.  Until we figure out the
>          * real cause, disable tsched mode by telling the PCM info flag.
>          */
> -       if (chip->driver_caps & AZX_DCAPS_AMD_WORKAROUND)
> +       if ((chip->driver_caps & AZX_DCAPS_AMD_WORKAROUND) &&
> +           substream->stream == SNDRV_PCM_STREAM_CAPTURE)
>                 runtime->hw.info |= SNDRV_PCM_INFO_BATCH;
>         if (chip->align_buffer_size)
> In anyway, we need to know this change makes sense at all.  IOW, people need
> to check whether this causes yet another regression on the devices that have
> worked with BATCH workaround.

With the standard flags, Discord is perfect, Steam has stutters for the
first minute and a bit of delay (500 ms).

With the batch flag only on the capture stream, Steam is perfect,
Discord has delayed audio.

With the batch flag only on the playback stream, same thing with both of
them (first case).

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to pulseaudio in Ubuntu.

  Microphone distorted sound on ALC892/1220 on AMD chipsets

Status in Linux:
Status in linux package in Ubuntu:
  Won't Fix
Status in pulseaudio package in Ubuntu:
  Won't Fix

Bug description:
  Not sure if I'll report this upstream but there is definitely an issue
  with microphone recording on my desktop, this is not happening on my
  laptop which has a different codec.

  Already tried all workarounds possible, no luck. Only with my desktop
  with this particular motherboard. No issues in Windows, the sound
  recorded in there is distorted and has some static and robotic tone on

  alsa-info on the attachments

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to