No, pkexec per default does not start a graphical application for security 
If you want to start a graphical application with pkexec, you need a policy in 

But, nowadays, it mostly isn't necessary to start a graphical
application with elevated privileges, because there are better

On *buntu 18.04, synaptic does have a policy =>
You can start it with synaptic-pkexec. The same command is used in 

If it does not work and you have a policy, please check, that the
PolicyKit Authentication Agent is running (lxsession-default-apps in
section autostart) and logout/login.

I don't understand, how "su -l $other_user" is related to this bug

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to policykit-1 in Ubuntu.

  pkexec does not launch graphical authentication

Status in policykit-1 package in Ubuntu:

Bug description:
  Installed Trusty Tahr Lubuntu Beta1 version and added xubuntu desktop.  In 
buth desktops, I tried to launch synaptic to install some packages.  If I try 
to launch from menu, nothing seems to happen.  From a terminal, I ran
    pkexec "/usr/sbin/synaptic"
   and saw that it asks for password in the terminal window, instead of popping 
up an authentication window like previous Ubuntu version did.  That was why I 
saw no authentication request when launching from menu..  I have a 
workaround)launching from Terminal window), but this should be fixed before 

  ralph@minnie:~$ cat /etc/lsb-release 
  DISTRIB_DESCRIPTION="Ubuntu Trusty Tahr (development branch)"
  ralph@minnie:~$ pkexec --version
  pkexec version 0.105


To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to