Seeing same problem on my xubuntu machine after upgrade to 19.10. I
tried different GDM's (xubuntu, gnome, xfce) and tried different themes
(default, Adwaita, Breeze, DMZ). I have basic Intel graphics card with
minimal capabilities, and machine is used in production so I'm unable to
experiment much further. Logitech trackball mouse. I don't see anything
obvious in logs. Everything was working properly prior to upgrade. I'm
able to use the mouse to select and click, just no cursor is being
display so it's hard to see where the pointer is located. I'm assuming
this problem is related to this bug.

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.

  Ubuntu 19.10 upgrade results in invisible mouse cursor

Status in xorg package in Ubuntu:

Bug description:
  Following in place upgrade of Ubuntu 19.04 -> 19.10 I no longer have
  visible cursor with my Gnone desktop.

  I have found the same problem when upgrading 2 machines from Ubuntu
  19.04 -> 19.10.

  Reproducing problem is easy:

  1. Open Ubuntu Update Window
  2. Select "Upgrade"
  3. On completion of update (after reboot) cursor is no longer visible.
  4. This applies to display connected to VGA port on host with USB Keyboard + 

  While the connected display has no visible cursor and so is usable, I
  have always used X11VNC Server to provide network GUI access. On the
  remote X11VNC display I see and can use the cursor.

  This bug report is being sent via Remote X11VNC window, as I cannot
  use the main VGA display window (due to lack of visible cursor)

  I have done search online and thought that maybe issue was with my USB
  Mighty Mouse, so I also tried with Logitech M100R USB Mouse. Same
  result, no visible mouse cursor.

  I have done: "grep usb /var/log/syslog" and can see many USB events,
  including both Apple and Logitech mouse detection events.


  Due to compatibility issue with X11VNC, I have disable Wayland on both
  machines by adding the following option to: /etc/gdm3/custom.conf



  John Hartley.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.3.0-19.20-generic 5.3.1
  Uname: Linux 5.3.0-19-generic x86_64
  ApportVersion: 2.20.11-0ubuntu8.1
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Tue Nov  5 18:25:23 2019
  DistUpgraded: 2019-11-05 15:20:04,402 ERROR got error from PostInstallScript 
./ (g-exec-error-quark: Failed to execute child process 
“./” (No such file or directory) (8))
  DistroCodename: eoan
  DistroVariant: ubuntu
   Matrox Electronics Systems Ltd. G200eR2 [102b:0534] (rev 01) (prog-if 00 
[VGA controller])
     Subsystem: Lenovo G200eR2 [1d49:0a01]
  InstallationDate: Installed on 2018-12-17 (322 days ago)
  InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 
  MachineType: LENOVO System x3650 M5: -[8871AC1]-
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-19-generic 
root=UUID=3b8f415b-7e78-461c-83df-64f1f1a7826a ro ipv6.disable=1 quiet splash 
iommu=1 intel_iommu=on ipv6.disable=1 vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: Upgraded to eoan on 2019-11-05 (0 days ago) 06/03/2019
  dmi.bios.vendor: LENOVO
  dmi.bios.version: -[TCE140H-2.91]-
  dmi.board.asset.tag: (none) 01KN179
  dmi.board.vendor: LENOVO
  dmi.board.version: NULL
  dmi.chassis.asset.tag: none
  dmi.chassis.type: 23
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: none
dmi:bvnLENOVO:bvr-[TCE140H-2.91]-:bd06/03/2019:svnLENOVO:pnSystemx3650M5-[8871AC1]-:pvr13:rvnLENOVO:rn01KN179:rvrNULL:cvnLENOVO:ct23:cvrnone: System X System x3650 M5: -[8871AC1]-
  dmi.product.sku: (none)
  dmi.product.version: 13
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.99-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.1-1ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to