Thank you for taking the time to report this bug and helping to make
Ubuntu better. It sounds like some part of the system has crashed. To
help us find the cause of the crash please follow these steps:

1. Look in /var/crash for crash files and if found run:
    ubuntu-bug YOURFILE.crash
Then tell us the ID of the newly-created bug.

2. If step 1 failed then look at where
ID is the content of file /var/lib/whoopsie/whoopsie-id on the machine.
Do you find any links to recent problems on that page? If so then please
send the links to us.

3. If step 2 also failed then apply the workaround from bug 994921,
reboot, reproduce the crash, and retry step 1.

Please take care to avoid attaching .crash files to bugs as we are
unable to process them as file attachments. It would also be a security
risk for yourself.

** Package changed: xorg (Ubuntu) => xorg-server (Ubuntu)

** Changed in: xorg-server (Ubuntu)
       Status: New => Incomplete

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.

  crashes or freezes with nividia/xorg

Status in xorg-server package in Ubuntu:

Bug description:
  I have plugged in my Dell precision 5530 laptop a 4k HDMI screen.
  Using it with 200% zoom makes xorg crash.
  I have used proprietary 430, and changed to recommended proprietary 435 
nvidia driver.
  As the system was still very unstable (no to say unusable) I had a go with 
440 from ppa.
  I also ensured that my system was up to date doing a sudo apt-get update and 
upgrade. I was suprised to discover a few packages that needed an upgrade 
although I had previously used the Software Updater tool. Maybe I was doing 
something wrong.
  Anyway, with these updates and the newer 440 driver, I have successfully 
worked a day (sparsely) without problem, and using only 100% zoom.
  As a test, I decided to try to set the zoom to 200% (through devices > 
display, and I have only the external display enabled).
  After several minutes, I clicked on the « full screen » icon to maximize a 
shell, and the PC froze.
  It was so close to my change in the zoom ratio, that I suspect this is 

  dmesg shew me that NVRM had a problem :
  [97501.301998] NVRM: GPU at PCI:0000:01:00: 
  [97501.302000] NVRM: Xid (PCI:0000:01:00): 32, pid=493, Channel ID 00000018 
intr 00040000
  [97501.302134] NVRM: Xid (PCI:0000:01:00): 32, pid=2052, Channel ID 00000018 
intr 00200000
  [97501.317307] NVRM: Xid (PCI:0000:01:00): 69, pid=902, Class Error: ChId 
001b, Class 0000902d, Offset 00000250, Data 000055d3, ErrorCode 0000000c

  pid 493 is gone

  pid 2052 is xorg
  stan      2052  2050  1 mars20 tty2    00:25:38 /usr/lib/xorg/Xorg vt2 
-displayfd 3 -auth /run/user/1000/gdm/Xauthority -background none -noreset 
-keeptty -verbose 3

  pid 902 is nvidia driver
  root       902     2  0 mars20 ?       00:02:59 [irq/163-nvidia]

  ppid 2052 is 2050 :
  stan      2050  2004  0 mars20 tty2    00:00:00 /usr/lib/gdm3/gdm-x-session 
--run-script env GNOME_SHELL_SESSION_MODE=ubuntu /usr/bin/gnome-session 
--systemd --session=ubuntu

  After such an event, the previous days, the system became unstable,
  and I have got problems with other devices such as audio and network.

  If I run the manufacturer self-check test, everything is fine.

  ProblemType: Bug
  DistroRelease: Ubuntu 19.10
  Package: xorg 1:7.7+19ubuntu12
  ProcVersionSignature: Ubuntu 5.3.0-42.34-generic 5.3.18
  Uname: Linux 5.3.0-42-generic x86_64
  NonfreeKernelModules: nvidia_modeset nvidia
  .proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: 
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.suspend: suspend hibernate resume
  .proc.driver.nvidia.suspend_depth: default modeset uvm
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  440.64  Fri Feb 21 01:17:26 
UTC 2020
   GCC version:  gcc version 9.2.1 20191008 (Ubuntu 9.2.1-9ubuntu2)
  ApportVersion: 2.20.11-0ubuntu8.6
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CompizPlugins: No value set for 
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Sat Mar 21 18:36:53 2020
  DistUpgraded: 2019-11-04 11:06:46,434 ERROR got error from PostInstallScript 
./ (g-exec-error-quark: Failed to execute child process 
“./” (No such file or directory) (8))
  DistroCodename: eoan
  DistroVariant: ubuntu
   nvidia, 440.64, 5.3.0-42-generic, x86_64: installed
   virtualbox, 6.0.14, 5.3.0-40-generic, x86_64: installed
   virtualbox, 6.0.14, 5.3.0-42-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
   Intel Corporation UHD Graphics 630 (Mobile) [8086:3e9b] (prog-if 00 [VGA 
     Subsystem: Dell UHD Graphics 630 (Mobile) [1028:087d]
     Subsystem: Dell GP107GLM [Quadro P2000 Mobile] [1028:087d]
  InstallationDate: Installed on 2019-04-26 (329 days ago)
  InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
  MachineType: Dell Inc. Precision 5530
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-42-generic 
root=UUID=2262d308-663c-47c3-9e75-b34611c8df1d ro nouveau.blacklist=1 
acpi_rev_override=1 acpi_osi=Linux nouveau.modeset=0 pcie_aspm=force 
drm.vblankoffdelay=1 scsi_mod.use_blk_mq=1 nouveau.runpm=0 
mem_sleep_default=deep quiet splash vt.handoff=7
  SourcePackage: xorg
  UpgradeStatus: Upgraded to eoan on 2019-11-04 (138 days ago) 12/25/2019
  dmi.bios.vendor: Dell Inc.
  dmi.bios.version: 1.15.0 0N0DK2
  dmi.board.vendor: Dell Inc.
  dmi.board.version: A00
  dmi.chassis.type: 10
  dmi.chassis.vendor: Dell Inc.
dmi:bvnDellInc.:bvr1.15.0:bd12/25/2019:svnDellInc.:pnPrecision5530:pvr:rvnDellInc.:rn0N0DK2:rvrA00:cvnDellInc.:ct10:cvr: Precision Precision 5530
  dmi.product.sku: 087D
  dmi.sys.vendor: Dell Inc.
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.99-1ubuntu1
  version.libgl1-mesa-dri: libgl1-mesa-dri 19.2.8-0ubuntu0~19.10.3
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.5+git20191008-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.0.1-1ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to