It appears you are using graphics packages from the 'oibaf' PPA, which
is not supported and is known to be buggy.

Please remove that PPA from your system and if the problem persists then
open a new bug.

** Changed in: xorg (Ubuntu)
       Status: New => Invalid

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to xorg in Ubuntu.

  Screen flickering in Kubuntu 20.04 on Lenovo Yoga C940 14-IIL

Status in xorg package in Ubuntu:

Bug description:
  I'm experiencing a problem extremely similar to
  My screen flickers too on a fresh install of Kubuntu 20.04LTS

  Results of `inxi -Gx`  
  Graphics:  Device-1: Intel Iris Plus Graphics G7 vendor: Lenovo driver: i915 
v: kernel bus ID: 00:02.0 
             Display: x11 server: X.Org 1.20.8 driver: modesetting resolution: 
             OpenGL: renderer: Mesa Intel Iris Plus Graphics (ICL GT2) 
             v: 4.6 Mesa 20.1.0-devel (git-a64d266 2020-04-25 focal-oibaf-ppa) 
direct render: Yes 

  I've tried 915.enable_psr=0 as a boot parameter, didn't work.
  nomodeset does get me into a bootable image, but I'm looking into getting a 
working driver.

  Fedora 31 was having a similar issue, there was barely any flickering up 
untill some recent kernel updates. (about a couple small ones every 10 minutes 
or so)
  Kubuntu 19.10 was quite stable too, untill I installed a lenovo provided 
firmware update (from AUCN45WW to AUCN54WW), which made it slightly worse.
  I also tried a couple of other kernel parameters that haven't had any effect.
  Running kernel 5.6 on Kubuntu did have thesame issue as regular kubuntu 20.04.
  Running kernel 5.7-rc2 did fix the problem, but networking and sound was 
dead, so it's only half a solution.
  I highly suspect it's an issue with i915, but I don't know how I would trace 
it down.
  I don't know why and I don't know how.

  ProblemType: Bug
  DistroRelease: Ubuntu 20.04
  Package: xorg 1:7.7+19ubuntu14
  ProcVersionSignature: Ubuntu 5.4.0-26.30-generic 5.4.30
  Uname: Linux 5.4.0-26-generic x86_64
  ApportVersion: 2.20.11-0ubuntu27
  Architecture: amd64
  BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
  CasperMD5CheckResult: skip
  CompositorRunning: None
  CurrentDesktop: KDE
  Date: Sat Apr 25 20:49:36 2020
  DistUpgraded: Fresh install
  DistroCodename: focal
  DistroVariant: ubuntu
   Intel Corporation Iris Plus Graphics G7 [8086:8a52] (rev 07) (prog-if 00 
[VGA controller])
     Subsystem: Lenovo Iris Plus Graphics G7 [17aa:3801]
  InstallationDate: Installed on 2020-04-25 (0 days ago)
  InstallationMedia: Kubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
  MachineType: LENOVO 81Q9
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-5.4.0-26-generic 
root=UUID=5d977dfa-1fa5-412b-9d83-644cef18af6e ro rootflags=subvol=@ quiet 
splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: No upgrade log present (probably fresh install) 01/09/2020
  dmi.bios.vendor: LENOVO
  dmi.bios.version: AUCN54WW
  dmi.board.asset.tag: NO Asset Tag LNVNB161216
  dmi.board.vendor: LENOVO
  dmi.board.version: SDK0J40709 WIN
  dmi.chassis.asset.tag: NO Asset Tag
  dmi.chassis.type: 31
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Lenovo Yoga C940-14IIL
dmi:bvnLENOVO:bvrAUCN54WW:bd01/09/2020:svnLENOVO:pn81Q9:pvrLenovoYogaC940-14IIL:rvnLENOVO:rnLNVNB161216:rvrSDK0J40709WIN:cvnLENOVO:ct31:cvrLenovoYogaC940-14IIL: Yoga C940-14IIL 81Q9
  dmi.product.sku: LENOVO_MT_81Q9_BU_idea_FM_Yoga C940-14IIL
  dmi.product.version: Lenovo Yoga C940-14IIL
  dmi.sys.vendor: LENOVO
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.101+git2004241830.bf63f8~oibaf~f
  version.libgl1-mesa-dri: libgl1-mesa-dri 20.1~git2004250730.a64d26~oibaf~f
  version.libgl1-mesa-glx: libgl1-mesa-glx N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to