** Changed in: mediascanner2 (Ubuntu)
       Status: Triaged => Fix Released

** Changed in: mediascanner2 (Ubuntu)
     Assignee: (unassigned) => zawlatt (ayngzawlatt)

You received this bug notification because you are a member of Ubuntu
Touch seeded packages, which is subscribed to mediascanner2 in Ubuntu.

  mediascanner prevents unmounting usb device

Status in mediascanner2 package in Ubuntu:
  Fix Released

Bug description:
  Trying to unmount a block device I just mounted, I get the following
  error (sorry for not resetting the locale. It says "Device is busy"):

  :~$ sudo umount /media/tkluck/tjk-backup 
  umount2: Apparaat of hulpbron is bezig
  umount: /media/tkluck/tjk-backup: apparaat is bezig
          (Welke processen het apparaat gebruiken kan mogelijk
           gevonden worden met behulp van lsof(8) of fuser(1).)
  umount2: Apparaat of hulpbron is bezig

  I get the same error in a dialog window when trying to unmount from
  the file manager.

  Using lsof shows that the media-scanner daemon is the culprit:

  tkluck@ultrabook-tjk:~$ lsof /media/tkluck/tjk-backup 
  mediascan 2898 tkluck   16r   DIR  252,3   249856        2 
  mediascan 2898 tkluck   17r   DIR  252,3     4096 50855937 <REDACTED>
  mediascan 2898 tkluck   18r   DIR  252,3     4096 39080372 <REDACTED>
  mediascan 2898 tkluck   19r   DIR  252,3    12288 39080513 <REDACTED>
  mediascan 2898 tkluck   20r   DIR  252,3    20480 39080525 <REDACTED>
  mediascan 2898 tkluck   21r   DIR  252,3     4096 46792990 <REDACTED>
  mediascan 2898 tkluck   22r   DIR  252,3     4096 46792991 <REDACTED>
  mediascan 2898 tkluck   23r   DIR  252,3    16384 46793749 <REDACTED>
  mediascan 2898 tkluck   24r   DIR  252,3     4096 47317994 <REDACTED>
  mediascan 2898 tkluck   25r   DIR  252,3     4096 47317997 <REDACTED>
  mediascan 2898 tkluck   26r   DIR  252,3     4096 47317999 <REDACTED>

  Sending it

  sudo kill -9 2898

  solved this for me.

  This is on Ubuntu GNOME 14.04. I uninstalled the mediascanner2.0 to
  solve this "once and for all" (which has no other impact since I do
  not use Unity).

  My guess is that the scan usually finishes quickly after mounting. But
  because this particular drive contains a big filetree, it doesn't,
  resulting in the issue.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~touch-packages
Post to     : touch-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~touch-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to